Entity records may not appear correctly in Microsoft Dynamics CRM 3.0 (912894)



The information in this article applies to:

  • Microsoft CRM 3.0

SYMPTOMS

When you work with an entity in an associated view in Microsoft Dynamics CRM 3.0, you may experience the following symptoms:
  • The entity records do not appear correctly. For example, each record shows as two rows.
  • When you double-click a record, the record does not open.
  • When you try to delete a record, the record is not deleted. You receive the following error message:
    You must select one or more records before you can perform this action.

CAUSE

These issues may occur when you create an attribute that has the same schema name as the entity. The entity and each of its attributes have a schema name property. This issue occurs when the following conditions are true:
  • One of the attributes has the same schema name as the entity.
  • This attribute appears as a column in the associated view for the entity.

RESOLUTION

To resolve these issues, make sure that the schema name that you specify for any attribute differs from the schema name for the entity.

For example, if you create a new entity that is named Bank Account and if the schema name is set as new_bankaccount, do not specify new_bankaccount as the schema name of the primary attribute. Additionally, make sure that no other newly created attributes have the same schema name as the entity.

MORE INFORMATION

To create an entity, follow these steps:
  1. Log on to Microsoft Dynamics CRM as a user who has the System Customizer or System Administrator role.
  2. Click Settings, click Customization, and then click Customize Entities.
  3. Click New.

Modification Type:MinorLast Reviewed:8/25/2006
Keywords:kbMBScustomization kberrmsg kbtshoot kbMBSMigrate kbprb KB912894 kbAudDeveloper kbAudEndUser