FIX: Error message in the Single Sign-On Migration utility when you try to import data from a Host Account Cache database to an Enterprise Single Sign-On database: "Invalid password or key file" (912769)



The information in this article applies to:

  • Microsoft Host Integration Server 2004

SYMPTOMS

When you use the Single Sign-On (SSO) Migration utility (Hisssomig.exe) in Microsoft Host Integration Server 2004 to import data from a Host Account Cache database to an Enterprise Single Sign-On (SSO) database, you may receive the following error message:
Invalid password or key file
Additionally, information that is similar to the following may be logged in the log file that the SSO Migration utility creates:
*** Log started on DateTime
[Time Info] Validating the file integrity
[Time Info] The validation succeeded
[Time Info] Decrypting the passwords
[Time Error] An error has occured while decrypting passwords (Invalid password or key file.
[Time Error] The import failed (Invalid password or key file)
*** Log closed on DateTime
Note In the log entry, "occured" is a misspelling of the word "occurred."

This problem occurs when the following conditions are true:
  • You are importing data that was exported from a Host Account Cache database.
  • The SSO Migration utility is running on a Microsoft Windows Server 2003-based computer.
  • You are exporting and importing data from a Host Account Cache database that is located on a Microsoft Windows 2000 Server-based computer.
Note This problem does not occur when the computer on which the SSO Migration utility is running and the computer where the Host Account Cache database is located are running the same version of the Microsoft Windows operating system.

CAUSE

The SSO Migration utility and the Udbkey.exe utility were designed to use the default Cryptographic Service Provider (CSP) of the operating system on which these utilities are installed. The problem occurs because the default CSP on Windows Server 2003 differs from the default CSP on Windows 2000 Server. Therefore, the SSO Migration utility that is running on a Windows Server 2003-based computer cannot decrypt data from a Host Account Cache database that is located on a Windows 2000 Server-based computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Host Integration Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirement
Hisssomig.exe6.0.2007.061,44024-Jan-200601:55x86SP1
Udbkey.exeNot Applicable111,10424-Jan-200601:55x86SP1
Note Because of file dependencies, the most recent hotfix that contains these files may contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The Host Integration Server 2004 SSO migration utility is described in the Host Integration Server 2004 documentation under the topic "Upgrading from Host Integration Server 2000 or SNA Server 4.0." To view this topic, type Upgrading from Host Integration Server 2000 in the documentation Search box.

Note To view this topic online, visit the following Microsoft Developer Network (MDSN) Web site:The documentation explains the steps to perform the migration. However, some items are not clearly explained and may cause problems during the migration. The following information outlines the steps that are required to perform the migration from a Host Account Cache database to an Enterprise SSO database:
  1. Install Enterprise SSO on the system that will operate as the Master Secret Server (MSS). For more information, see the "Security User's Guide" topic in the Host Integration Server 2004 Documentation.
  2. Copy the updated Hisssomig.exe file to the Enterprise SSO Master Secret Server.
  3. Copy the Scrypt.dll file from the Support\Utilities\ folder on the Host Integration Server 2004 image to the same location as the Hisssomig.exe file on the Enterprise SSO Master Secret Server.

    Note If the Scrypt.dll file is not in the same location as the Hisssomig.exe file, an error message that is similar to the following is logged in the migration log file when you try to import the exported data:
    [Time Error] The import failed (The type initializer for "Microsoft.SSO.Migration.DecryptionHandler" threw an exception.)
  4. Copy the updated Udbkey.exe file to the primary domain controller (PDC) Emulator that hosts the master Host Account Cache database.
  5. At a command prompt, locate the folder that contains the Udbkey.exe utility.
  6. Run the following command to export the encryption key that the Host Account Cache database uses:

    udbkey -output filename -password password

    Note If you run the udbkey command without parameters, the expected syntax for the command is displayed.
  7. Copy the encryption key file that the Udbkey.exe utility created in step 6 to the Enterprise SSO Master Secret Server. Copy this file to the same location as the Hisssomig.exe file and the Scrypt.dll file.
  8. Export the data from the Host Account Cache database. To do this, run the following command:

    hisssomig -export -server servername -output XML file name

    Note Replace servername with the name of the server that is hosting the master Host Account Cache database. Replace XML file name with the name of the file to which you want the exported data written.

    Note If you run the hisssomig command without parameters, the expected syntax for the command is displayed.
  9. Import the data into the Enterprise SSO database. To do this, run the following command:

    hisssomig -import -input XML file name -key filename -password password

    Note Replace XML file name with the name of the file to which the exported data was written in step 8. Replace filename with the name of the encryption key file that the Udbkey.exe utility created in step 6. Replace password with the password that you used in step 6.

REFERENCES

To obtain the Host Integration Server 2004 documentation, visit the following Microsoft Download Center Web site: For more information, you can also download the following Microsoft white paper:

Single Sign-On services for Microsoft enterprise application integration solutions
http://download.microsoft.com/download/c/6/5/c65ff9fd-0ed7-47f6-91ab-000e6265ea5b/enterprise_sso_whitepaper.doc

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

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Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbHIS2004 kbfix kbbug kbpubtypekc KB912769 kbAudDeveloper kbAudITPRO