The Snmp.exe process generates an access violation when the event is converted to an SNMP trap in MOM 2005 (912704)



The information in this article applies to:

  • Microsoft Operations Manager 2005
  • Microsoft Operations Manager 2005 SP1

SYMPTOMS

You configure a Microsoft Operations Manager (MOM) 2005 agent rule to forward an event as a Simple Network Management Protocol (SNMP) trap. However, the Snmp.exe process generates an access violation when the event is converted to an SNMP trap.

This behavior causes both the Snmp.exe process and the Momservice.exe process to stop. You also receive an error message that is similar to the following:
Program Error
Snmp.exe has generated errors and will be closed by Windows. You will need to restart the program. An error log is being created.
Additionally, an event that is similar to the following is logged in the System log:
Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7037
Date: Date
Time: Time
User: N/A
Computer: Computer Name
Description:
The SNMP Service service terminated unexpectedly

CAUSE

This problem occurs if MOM 2005 tries to convert an event to an SNMP trap when the event description field is larger than 1024 bytes. However, this problem typically occurs when an event description field is larger than approximately 13,000 bytes.

Note The size of an event description field varies, depending on the environment. For example, when event ID 80 occurs together with an event source of DataTransformationServices, this event has a large description field.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Operations Manager service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Microsoft Operations Manager Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTime
Snmpextnagent.dll5.0.2911.2912,80019-Jan-200619:38

Installation instructions

Apply this hotfix to each computer that meets one of the following conditions:
  • All MOM 2005 Service Pack 1 (SP1) computers
  • All computers that are running the MOM 2005 agent
Manually apply this hotfix to every MOM 2005 server in your MOM management groups. To do this, follow these steps:
  1. Use the MOM 2005 Administrator console to apply this hotfix to MOM 2005 agents whose control level is set to Full. The MOM 2005 agents that can be automatically patched are listed in the following folder:

    Microsoft Operations Manager (ServerName)\Administration\Computers\Pending Actions

  2. Manually apply this hotfix to every MOM 2005 agent whose control level is set to None. These agents are listed in the following folder:

    Microsoft Operations Manager (ServerName)\Administration\Computers\Agent-managed Computers

  3. Apply this hotfix to MOM agent computers whose control level was set to Full after this hotfix was applied to the MOM server. You can manually apply this hotfix, or you can configure the MOM server to apply this hotfix. To configure the MOM server to apply this hotfix, follow these steps:
    1. In the MOM Administrator console, expand Administration, expand Computers, and then click Pending Actions.
    2. Right-click the computer in question, and then click Approve Manual Agent Installation Now.
    3. Click the Agent-managed Computers folder.
    4. In the right pane, right-click the MOM 2005 agent, and then click Update Agent Settings.
For more information about how to install software updates in a MOM environment, see the "Patches for MOM 2005" section in the MOM 2005 Operations Guide.

Additional notes

After you apply this hotfix, MOM 2005 will truncate any event description string that is larger than 1024 bytes before MOM converts the event to an SNMP trap.

WORKAROUND

To work around this problem, do not configure MOM 2005 to send SNMP traps for events that have description fields that are larger than 1024 bytes. If a MOM agent is experiencing this problem, follow these steps to restart the SNMP service:
  1. Set the DataAvailable value under the following registry subkey to 0:

    HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OnePoint\SNMP\Data

  2. Start the SNMP service.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbSNMPAgent kbExpertiseAdvanced kbfix kbBug kbQFE kbpubtypekc KB912704 kbAudITPRO