You may experience a system memory leak of private bytes in the Winlogon.exe process on a computer that is running Windows XP or Windows Server 2003 (912354)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Professional SP2
  • Microsoft Windows XP Home Edition SP1
  • Microsoft Windows XP Home Edition SP2

SYMPTOMS

You may experience a system memory leak of private bytes in the Winlogon.exe process on a computer that is running Microsoft Windows XP or Microsoft Windows Server 2003. When this occurs, the operating system becomes unresponsive and must be restarted.

CAUSE

If you do not log on the computer, a system memory leak may occur. Over time, the operating system may leak memory in the Winlogon.exe process at a rate of approximately 1 to 2 megabytes (MB) an hour.

RESOLUTION

Hotfix information

Microsoft Windows XP

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesTo apply this hotfix, you must have Windows XP Service Pack 1 (SP1) or Windows XP Service Pack 1 (SP2) installed on your computer.Restart requirementYou must restart your computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP, Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirement
Licdll.dll5.1.2600.1785398,84821-Dec-200503:36x86SP1
Winlogon.exe5.1.2600.1785483,32821-Dec-200503:16x86SP1
Windows XP, Service Pack 2
File nameFile versionFile sizeDateTimePlatformSP requirement
Licdll.dll5.1.2600.2815423,93621-Dec-200503:38x86SP2
Winlogon.exe5.1.2600.2815503,80821-Dec-200503:19x86SP2

Microsoft Windows Server 2003

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesNo prerequisites are required.Restart requirementYou must restart your computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Licdll.dll5.2.3790.457437,76021-Dec-200503:57x86
Winlogon.exe5.2.3790.457497,15221-Dec-200503:51x86
Windows Server 2003, 32-bit versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirement
Licdll.dll5.2.3790.2598450,04821-Dec-200504:12x86SP1
Winlogon.exe5.2.3790.2598509,44021-Dec-200503:58x86SP1
Windows Server 2003, x64-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatformSP requirement
Licdll.dll5.2.3790.2598736,25620-Dec-200512:27x64SP1
Winlogon.exe5.2.3790.2598924,16020-Dec-200512:27x64SP1
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe5.2.3790.457641,02420-Dec-200512:22IA-64
Windows Server 2003, Itanium-based versions with Service Pack 1
File nameFile versionFile sizeDateTimePlatform
Winlogon.exe5.2.3790.2598681,47220-Dec-200512:28IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbQFE kbhotfixserver kbpubtypekc KB912354 kbAudITPRO