The "Getting the domain information" part of the GPResult.exe command-line process takes a long time to finish on a member server that is running Windows Server 2003 (912263)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition

SYMPTOMS

Consider the following scenario. You run the Group Policy Results (GPResult.exe) command-line tool on a member server. The member server is running Microsoft Windows Server 2003. In this scenario, the "Getting the domain information" part of the tool's execution process takes a long time to finish. For example, this part of the process may take several minutes or more to finish.

CAUSE

This problem occurs when you run the Group Policy Results tool in an Active Directory forest where one or both of the following conditions are true:
  • There are many domains in the forest.
  • Many trusts in the forest are configured to external domains.
This problem occurs because the Group Policy Results tool parses every trust in the forest as part of the process to verify all the policy settings. If the Group Policy Results tool encounters one or more domains that are not reachable, the process takes longer to finish.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required to apply this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-bit editions
File nameFile versionFile sizeDateTimePlatform
Gprslt.exe5.2.3790.2645142,84823-Feb-200608:54x86
Windows Server 2003, x64 editions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gprslt.exe5.2.3790.2645206,84823-Feb-200612:07x64SP1SP1QFE
Wgprslt.exe5.2.3790.2645142,84823-Feb-200612:07x86SP1WOW
Windows Server 2003 for Itanium-based systems
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gprslt.exe5.2.3790.2645420,86423-Feb-200612:06IA-64SP1SP1QFE
Wgprslt.exe5.2.3790.2645142,84823-Feb-200612:06x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbBug kbfix kbQFE kbHotfixServer kbpubtypekc KB912263 kbAudITPRO