A DNS zone transfer between a BIND DNS server and a Windows Server 2003-based DNS server does not work when the BIND DNS server acts as a primary server (912233)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard Edition

SYMPTOMS

Consider the following scenario:

A primary Berkeley Internet Name Domain (BIND) DNS server sends a DNS zone transfer notification to a secondary Microsoft Windows Server 2003-based DNS server. The notification is part of the DNS zone transfer process. However, the DNS zone transfer does not work after the Windows Server 2003-based DNS server tries to load the changes from the primary DNS server.

Note The DNS zone transfer does work whenever the refresh interval elapses in the Start of Authority (SOA) record for the DNS zone. Additionally, you may notice that the DNS zone transfer works when you use the following options to initiate a manual zone transfer from a Windows Server 2003-based DNS server:
  • Transfer from Master
  • Reload from Master

CAUSE

This problem occurs because the Windows Server 2003-based DNS server uses a high port instead of port 53 to complete the following tasks:
  • To send an incremental zone transfer (IXFR) DNS query packet to the BIND DNS server.
  • To send a full zone transfer (AXFR) DNS query packet to the BIND DNS server.
The BIND DNS server must use the default port 53 to receive the query from the secondary Windows DNS server. When the Windows Server 2003-based DNS server uses a high port to send an IXFR or an AXFR DNS query packet to the BIND DNS server, a receiver is unavailable to receive the query. Therefore, the DNS zone transfer does not work.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dns.exe5.2.3790.455423,93617-Dec-200501:50x86NoneRTMQFE
Dns.exe5.2.3790.2594442,36817-Dec-200505:56x86SP1SP1QFE

Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dns.exe5.2.3790.4551,025,02416-Dec-200517:45IA-64NoneRTMQFE
Wdns.exe5.2.3790.455423,93616-Dec-200517:45x86NoneWOW
Dns.exe5.2.3790.25941,124,86417-Dec-200509:22IA-64SP1SP1QFE
Wdns.exe5.2.3790.2594442,36817-Dec-200509:22x86SP1WOW

Windows Server 2003 x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dns.exe5.2.3790.2594758,27217-Dec-200509:22x64SP1SP1QFE
Wdns.exe5.2.3790.2594442,36817-Dec-200509:22x86SP1WOW

WORKAROUND

To work around this problem, modify the BIND configuration file by adding the notify-source * port 53entry in the file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003SP1fix kbWinServ2003preSP1fix kbBug kbfix kbpubtypekc KB912233 kbAudITPRO