FIX: Error message when Profile Manager does not try to connect to the next available domain controller in Connected Services Framework Server 2.5: "The server is not operational" (912133)



The information in this article applies to:

  • Microsoft Connected Services Framework Server 2.5

SYMPTOMS

In Microsoft Connected Services Framework (CSF) Server 2.5, Profile Manager does not try to connect to the next available domain controller if the primary domain controller is unavailable. Profile Manager may fail, and you may receive the following error message:
The server is not operational.
Additionally, Identity Manager cannot connect to a domain controller. The following message is logged in the event log:Security ID structure is invalid.

CAUSE

The root cause is that Profile Manager does not try to connect to the secondary domain controller if the primary domain controller that is specified in the Identity Manager configuration file is not available. In other words, Identity Manager does not rebind the secondary domain controller when Identity Manager tries to find the available domain.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.Csf.Connector.Identitymanager.dll2.5.0.1084188,41602-Dec-200507:49x86
Microsoft.Csf.Connector.Profilemanagement.dll2.5.0.1084212,99202-Dec-200507:49x86

Installation information

The Microsoft.Csf.Connector.IdentityManager.dll file and the Microsoft.Csf.Connector.ProfileManagement.dll file in this hotfix are intended to replace the identically named files on the target system. You must replace these files manually.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:7/21/2006
Keywords:kbQFE kbfix KB912133 kbAudITPRO