When you configure the diagnostics logging level to Maximum on the NSPI Proxy service in Exchange Server 2003 Service Pack 1, event ID 9040 is logged in the Application log (912062)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition, Service Pack 1 (SP-1)
  • Microsoft Exchange Server 2003 Standard Edition, Service Pack 1 (SP1)

SYMPTOMS

When you set the diagnostics logging level to Maximum on the Name Service Provider Interface (NSPI) Proxy service in Microsoft Exchange Server 2003 Service Pack 1 (SP1), the following event is logged in the Application log:Event ID : 9040
Category : NSPI Proxy
Source : MSExchangeSA
Message : NSPI Proxy encountered an error while receiving a packet. The target Domain Controller or the network or a client might be down. The winsock subsystem returned the error:[0x2746]. The circuit that received this error is being closed.

CAUSE

After the NSPI Proxy service diagnostics logging level is set to Maximum, event ID 9040 is logged whenever a Collaboration Data Objects (CDO) script that opens a MAPI session runs on the server that is running Exchange Server 2003 SP1.

RESOLUTION

Event ID 9040 is non-disruptive and can safely be ignored.

MORE INFORMATION

For example, event ID 9040 is logged when the Exchange Management Pack runs the MAPI verification logon script to check mailbox availability. The Exchange Management Pack uses a CDO script that opens a MAPI session to perform this task.

How to configure Diagnostics Logging for the NSPI Proxy service

To configure Diagnostics Logging for the NSPI Proxy service, follow these steps:
  1. Start Exchange System Manager.
  2. If Display Administrative Groups is enabled, expand Administrative Groups, and then expand Your_Administrative Group. If Display Administrative Groups is not enabled, go to step 3.
  3. Expand Servers, right-click Your_Server_Name, and then click Properties.
  4. Click the Diagnostics Logging tab.
  5. Inthe Services list, click MSExchangeSA.
  6. In the Categories list, click NSPI Proxy.
  7. Under Logging Level, click Maximum, and then click OK.
  8. Quit Exchange System Manager.

Modification Type:MajorLast Reviewed:1/11/2006
Keywords:kbtshoot kbprb KB912062 kbAudITPRO