The Subject line of an e-mail activity may contain "&", "<", ">", or """ in Microsoft Dynamics CRM 3.0 (911986)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales for Outlook, when used with:
    • Microsoft CRM 3.0
  • Microsoft CRM 3.0
  • Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

You add a data field to the Subject line of an e-mail template in Microsoft Dynamics CRM 3.0. If you apply the template to an e-mail activity, the Subject line may show one or more of the following items:
  • &
  • <
  • >
  • "

CAUSE

This issue may occur when the text that is to be displayed on the Subject line of the e-mail activity contains any one of the following characters:
  • Ampersand (&)
  • Less than (<)
  • Greater than (>)
  • Quotation mark (")
For example, if you add the Account Name data field to the Subject line of an e-mail template and you create an e-mail activity for ABC & Company, the Subject line will contain the following text:

ABC &amp; Company

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft CRM service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this hotfix on computers that are running Microsoft CRM Server.

Prerequisites

There are no prerequisites.

Removal information

To remove this hotfix, use Add or Remove Programs in Control Panel.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Microsoft Dynamics CRM 3.0 Server
File nameFile versionFile sizeDateTime
Edit.aspxNot Applicable7,81522-Dec-200513:08

Microsoft Dynamics CRM 3.0 client for Outlook
File nameFile versionFile sizeDateTime
Edit.aspxNot Applicable7,81522-Dec-200513:08

Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers Server
File nameFile versionFile sizeDateTime
Edit.aspxNot Applicable7,81501-Jun-200623:02

Microsoft Dynamics CRM 3.0 Professional Edition for Service Providers Client
File nameFile versionFile sizeDateTime
Edit.aspxNot Applicable7,81501-Jun-200623:04

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MajorLast Reviewed:10/3/2006
Keywords:kbMBSemail kbMBSMigrate kbQFE kbHotfixServer kbpubtypekc KB911986 kbAudDeveloper kbAudEndUser