You experience slow system performance when you run a program that uses the WMI service on a Windows XP SP2-based computer or a Windows Server 2003 SP1-based computer (911262)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
  • Microsoft Windows Server 2003 SP1

SYMPTOMS

When you run a program that uses the Windows Management Instrumentation (WMI) service on a Microsoft Windows XP Service Pack 2 (SP2)-based computer or on a Microsoft Windows Server 2003 Service Pack 1(SP1)-based computer, you experience slow system performance. This problem gradually becomes worse as you continue to run the program.

CAUSE

This problem is caused by a memory leak that occurs when the memory that is used by a remote procedure call (RPC) cache is not freed. As the RPC cache grows larger, the program and Windows XP or Windows Server 2003 become increasingly unresponsive.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.1.2600.2810582,14413-Dec-200505:02x86

Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Rpcrt4.dll5.2.3790.2600643,07223-Dec-200500:51x86

Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.2.3790.26001,715,20022-Dec-200509:12x64SP1Not Applicable
Wrpcrt4.dll5.2.3790.2600626,68822-Dec-200509:12x86SP1WOW

Windows Server 2003, IA64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rpcrt4.dll5.2.3790.26002,460,16022-Dec-200509:14IA-64SP1Not Applicable
Wrpcrt4.dll5.2.3790.2600626,68822-Dec-200509:14x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbExpertiseInter kbQFE kbHotfixServer KB911262 kbAudEndUser