The ISA Server 2004 Firewall Client program no longer works after you update a computer to Microsoft Windows Vista Beta 2 (911077)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2004, Enterprise Edition
  • Microsoft Internet Security and Acceleration Server 2004, Standard Edition
  • Microsoft Windows Code Name "Longhorn"

Beta Information

This article discusses a Beta release of a Microsoft product. The information in this article is provided as-is and is subject to change without notice.

No formal product support is available from Microsoft for this Beta product. For information about how to obtain support for a Beta release, see the documentation that is included with the Beta product files, or check the Web location where you downloaded the release.

SYMPTOMS

After you update a computer to Microsoft Windows Vista Beta 2, the Microsoft Internet Security and Acceleration (ISA) Server 2004 Firewall Client program no longer works. Additionally, the Firewall Client Agent service no longer works. You may also receive the following error message when you try to configure the ISA Server 2004 Firewall Client program:
Firewall Client Agent is not accessible. The service is probably not running.
Note This problem occurs when you update the computer to Microsoft Windows Vista regardless of the original operating system. Additionally, when you try to use Windows Sockets (WinSock) programs over the Internet, these programs may not work in this situation.

CAUSE

This problem occurs because the ISA Server 2004 Firewall Client program is not compatible with Windows Vista.

MORE INFORMATION

The following files are located in the %SystemDrive%\Program Files\Microsoft Firewall Client 2004 folder:
  • FwcAgent.exe
  • FwcCreds.exe
  • FwcMgmt.exe
  • FwcRes.dll
  • FwcWsp.dll
  • ISAClient.htm
Note The Firewall Client Agent service may call these files.

Modification Type:MinorLast Reviewed:12/2/2005
Keywords:kberrmsg kbtshoot kbprb KB911077 kbAudITPRO