A cluster node failover does not work when you use SCSI-3-compliant persistent reservations in Windows Server 2003 SP1 (911030)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition

SYMPTOMS

A cluster node failover does not work when you use SCSI-3-compliant persistent reservations in the Device Specific Module (DSM) component in Microsoft Windows Server 2003 Service Pack 1 (SP1).

Additionally, after you update one cluster node to Microsoft Windows Server 2003 Service Pack 1 (SP1) and then move a disk resource to that node, the Cluster.log file contains the following error messages:
INFO Physical Disk <Disk E:>: [DiskArb]------- DisksOnline -------.
INFO Physical Disk <Disk E:>: [DiskArb] DisksOpenResourceFileHandle: Attaching to disk with signature 944c12e2
INFO Physical Disk <Disk E:>: [DiskArb] DisksOpenResourceFileHandle: Disk unique id present trying new attach
ERR Physical Disk <Disk E:>: [DiskArb] Signature of disk has changed or failed to find disk with id, old signature 0x944c12e2 new signature 0x944c12e2, status 2
ERR Physical Disk <Disk E:>: SCSI: Attach, error attaching to signature 944c12e2, error 2.
ERR Physical Disk <Disk E:>: Online: Unable to attach to signature 944c12e2. Error: 2.

CAUSE

This problem may occur if the following conditions are true:
  • You are using an array that is SCSI Primary Commands-3 (SPC-3)-compliant.
  • The multipath software maps Microsoft Cluster Service (MSCS) commands to equivalent persistent reservation commands.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Windows Server 2003 SP1 to install this hotfix.

Note x64-based versions of Windows Server 2003 do not require SP1 to install this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Clusdisk.sys5.2.3790.261168,60806-Jan-200602:41x86
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Clusdisk.sys5.2.3790.2611211,96806-Jan-200603:19IA-64
Windows, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Clusdisk.sys5.2.3790.2611111,61606-Jan-200603:18x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Event 1209 that occurs after you apply hotfix 911030 to a server cluster, click the following article number to view the article in the Microsoft Knowledge Base:

923424 Event 1209 occurs after you apply hotfix 911030 to a server cluster that is running Windows Server 2003 with Service Pack 1

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:10/11/2006
Keywords:kbHotfixServer kbExpertiseAdvanced kbQFE KB911030 kbAudITPRO