FIX: An application cannot play WMDRM-protected content or acquire licenses to play new WMDRM-protected content (910998)



The information in this article applies to:

  • Microsoft Windows Media Format 9.5 SDK

SYMPTOMS

When you use Microsoft Windows Media Player or an application that is built on the Windows Media Format 9.5 SDK, you experience the following behavior:
  • The application cannot play Windows Media Digital Rights Management (WMDRM) protected content.
  • The application cannot acquire licenses to play new WMDRM-protected content.

CAUSE

Microsoft is still investigating the cause of this issue.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next release that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have the update that is described in Microsoft Knowledge Base (KB) article 891122 installed to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

891122Update for Windows Media Digital Rights Management-enabled players

Windows Media Player 10 on Windows XP

The following file is available for download from the Microsoft Download Center:
DownloadDownload the WindowsMedia10-KB910998-x86-INTL.exe package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformOperating system
Blackbox.dll10.0.0.3991290,81607-Dec-200512:05x86Windows XP
Drmv2clt.dll10.0.0.3991505,34407-Dec-200512:05x86Windows XP

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This hotfix does not specifically fix an issue with the WMDRM system. After you apply this hotfix, the WMDRM system tries to reinitialize itself to allow for correct playback if the computer becomes unable to play protected content.

When the WMDRM system reinitializes, a user must reacquire or restore licenses for any protected content that is currently stored on the computer.

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbfix kbQFE kbHotfixServer KB910998 kbAudDeveloper kbAudEndUser kbAudOEM