You cannot create a new area in SharePoint Portal Server 2003 after you install Windows SharePoint Services Service Pack 2 (910764)
The information in this article applies to:
- Microsoft Office SharePoint Portal Server 2003
- Microsoft Windows SharePoint Services
SYMPTOMS
Consider the following scenario. You install Microsoft Windows SharePoint Services Service Pack 2 (SP2). Then, you try to create a new area in Microsoft SharePoint Portal Server 2003. In this scenario, you may receive the following error message when you try to create a new area in SharePoint Portal Server 2003:
An error has occurred in the portal site. Contact the portal site administrator for assistance.
CAUSE
The problem occurs because the file time stamps on the SharePoint SQL script files are incorrect. These files are located in the following folder:
Drive:\Program Files\Common Files\Microsoft Shared\web server extensions\60\TEMPLATE\SQL
Because the time stamps are incorrect, Windows SharePoint Services SP2 does not update these files. Therefore, the stored procedures for the content databases are not updated.
RESOLUTION
To resolve this problem, follow these steps:
- Remove the *.SQL files from the following folder:
Drive:\Program Files\Common Files\Microsoft Shared\web server extensions\60\TEMPLATE\SQL - In Control Panel, double-click Add or Remove Programs.
- Click the Windows SharePoint Services installation in the list of programs, and then click Change.
- Click Reinstall or Repair Microsoft Windows SharePoint Services 2.0 to its original state, and then click Next.
After the repair is completed, you must force an upgrade so that the stored procedures on the content databases are updated. To complete this step, use the Stsadm.exe command-line tool to force an upgrade of the content databases:
- Click Start, click Run, type CMD in the Open box, and then click OK.
- At the command prompt, type the following lines, and then press ENTER after each line:
cd /d %commonprogramfiles%\Microsoft Shared\Web Server Extensions\60\Bin
stsadm -o upgrade -forceupgrade
exit
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Modification Type: | Major | Last Reviewed: | 12/7/2005 |
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Keywords: | kbExpertiseInter kbtshoot KB910764 kbAudITPRO |
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