Error message when you try to open e-mail messages that you downloaded by using the Pine e-mail client in Exchange Server 2003: "Not a string (<Date>)" (910721)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

Consider the following scenario. You use the Pine program as an Internet Message Access Protocol 4 (IMAP4) e-mail client to download e-mail messages. These e-mail messages are located on a server that is running Microsoft Exchange Server 2003. In this scenario, you receive one of the following error messages when you try to open some of the downloaded e-mail messages:
  • Not a string: (Date...)
  • Junk at end of body part: (Date...)

CAUSE

This problem occurs when the header of the e-mail message contains the following entry:

Content-type: message/rfc822

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you install the hotfix.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Eximap4.dll6.5.7650.1384,48018-Dec-200502:21x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This problem has only been reported when you use the Pine e-mail client program as an IMAP4 client. However, you may experience this problem with other IMAP4 client programs if the following conditions are true:
  • The IMAP client program uses the FETCH BODYSTRUCTURE command to retrieve the message structure of an e-mail message.
  • The header of the e-mail message contains the following entry:

    Content-type: message/rfc822

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbfix kbBug kbpubtypekc KB910721 kbAudITPRO