A network communication program may stop responding when you use Windows Server 2003 to implement Winsock Direct in a fast SAN environment (910481)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

When you use Microsoft Windows Server 2003 to implement Winsock Direct (WSD) in a fast System Area Network (SAN) environment, you may experience any one of the following WSD-related problems:
  • The network communication program stops responding when you send lots of data.
  • Data that is sent over the network is not received correctly. Data corruption may occur.
  • You receive access violation error messages in the network communication program.
  • Unexpected behavior occurs in the network communication program.

CAUSE

These problems may occur if you are using a Remote Direct Memory Access (RDMA)-capable network or the InfiniBand network architecture to enable WSD. Problems may occur because of timing issues.

RESOLUTION

Update information

The following files are available for download from the Microsoft Download Center:

Windows Server 2003, x86-based versions

DownloadDownload the 910481 package now.

Windows Server 2003, x64-based versions

DownloadDownload the 910481 package now.

Windows Server 2003, Itanium-based versions

DownloadDownload the 910481 package now.

Release Date: March 10, 2006

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Mswsock.dll5.2.3790.2589256,51209-Dec-200505:20x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mswsock.dll5.2.3790.2589489,47209-Dec-200505:56x64SP1SP1QFE
Wmswsock.dll5.2.3790.2589231,93609-Dec-200505:56x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Mswsock.dll5.2.3790.2589781,31209-Dec-200505:56IA-64SP1SP1QFE
Wmswsock.dll5.2.3790.2589231,93609-Dec-200505:56x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer ATdownload kbExpertiseAdvanced KB910481 kbAudOEM