You may receive a "MEM_BAD_POINTER" error message on a computer that is running Windows XP with Service Pack 2 (910466)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

When you run a program that uses MicroQuill SmartHeap heap management software on a computer that is running Microsoft Windows XP with Service Pack 2, you may receive an error message that is similar to the following:
MEM_BAD_POINTER

CAUSE

This problem occurs if the Install files for East Asian languages check box is selected in the Regional and Language Options Control Panel item.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Usp10.dll1.420.2600.2791406,01608-Nov-200502:24x86

WORKAROUND

To work around this problem, follow these steps:
  1. Click Start, click Run, type intl.cpl in the Open box, and then click OK.
  2. Click the Languages tab, click to clear the Install files for East Asian languages check box and the Install files for complex script and right-to-left languages check box, and then click OK two times.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:9/13/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug kbpubtypekc KB910466 kbAudITPRO