When you print a document in Word or in PowerPoint on a computer that is running a 64-bit version of Windows, Word or PowerPoint may stop responding (910289)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

You try to print a document in Microsoft Word or in Microsoft PowerPoint on a computer that is running a 64-bit version of Microsoft Windows. After you do this, Word or PowerPoint may stop responding.

CAUSE

This problem may occur if the following conditions are true:
  • The document contains imported Microsoft Excel graphs or embedded Windows metafiles (.wmf files).
  • You print the document by using raw mode.

    Note The problem does not occur when you print the document by using enhanced metafile format (EMF) mode.
The problem occurs because of an issue in Microsoft Windows Server 2003 Service Pack 1 (SP1).

Note Windows Server 2003 SP1 is included in the x64 versions of Windows.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. x64-based versions of Windows Server 2003 and Microsoft Windows XP
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.2569609,79212-Nov-200504:33x64SP1SP1QFE
Wgdi32.dll5.2.3790.2569285,18412-Nov-200504:33x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gdi32.dll5.2.3790.2569907,26412-Nov-200504:33IA-64SP1SP1QFE
Wgdi32.dll5.2.3790.2569285,18412-Nov-200504:33x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Print jobs are sent in various formats. Each format is suited to different computing environments. The following formats are available:
  • EMF
    EMF is a highly portable format. The instructions for the print job are assembled on the user's computer, and then the spooler finishes processing the job. EMF data is created by the Graphics Device Interface (GDI). After an EMF job is sent to the spooler, control is returned to the user, and the spooler finishes processing the job. This sequence limits how long the user's computer is busy.
  • RAW
    When you use the RAW data type, the print job is sent directly to the printer. The spooler does not modify RAW data.
  • RAW [FF Appended]
    RAW [FF Appended] is exactly like the RAW data type except that a form-feed character is appended to the end of each print job. The last page of a RAW data type document does not print on a Printer Control Language (PCL) printer. Therefore, you do not have to append a form-feed character.
  • RAW [FF Auto]
    RAW [FF Auto] is the same as the RAW data type except that the spooler examines the document for a form-feed character at the end of the job. If there is no form-feed character, the spooler adds one.
  • Text
    Text format tells the spooler that the data is ANSI text. The text is modified by the print processor if it is required. The print processor takes the text and calls GDI for playback. The text is printed by using the printer's default font.

    Text data is composed of values from 0 through 255. Each value represents a different character. Text data is based on the ANSI standard. If an application that has another character set creates text data, the text data does not print. This problem frequently occurs when data uses the extended character range. This range is represented by values that are more than 127.

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:11/29/2005
Keywords:kbExpertiseAdvanced kbQFE KB910289 kbAudOEM