The "Sender ID Filtering" feature does not work correctly in an Exchange Server 2003 SP2 server (910272)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

Consider the following scenario. An external server sends e-mail messages to a server that is running Microsoft Exchange Server 2003 Service Pack 2 (SP2). The Exchange Server 2003 SP2 server has the Sender ID Filtering feature enabled. In this scenario, the following symptoms may occur:
  • E-mail messages are rejected even though the sending server is included in the Sender Policy Framework (SPF) record.
  • E-mail messages are accepted even though the sending server is not included in the SPF record.

CAUSE

This problem occurs because of a problem in the way that the Exchange Sender ID engine applies subnet masks that are defined in the SPF records. The problem may occur if one or more non-class full subnets are defined in the SPF record of the sending domain. The following list contains two examples of non-class full subnets that may be defined in the SPF record of the sending domain:
  • v=spf1 ip4:10.0.0.128/25
  • v=spf1 ip4:10.0.63.0/18 -all
Note Generally, this problem does not occur when class full subnets are defined in the SPF record of the sending domain. The following list contains two examples of class full subnets:
  • 10.0.0.0/16
  • 10.0.0.0/24

RESOLUTION

Hotfix information

Prerequisites

Because of file dependencies, this software update requires Microsoft Exchange Server 2003 Service Pack 2 (SP2)

Restart requirement

Microsoft Internet Information Services (IIS) and IIS-dependent services are stopped when you install this software update

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exhotfixuninst.dll6.5.7233.4113,82408-Aug-200522:02x86
Msgfilter.dll6.5.7650.11205,31214-Dec-200520:08x86
Exhotfix.cdfNot Applicable2,28215-Dec-200500:25Not Applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:9/6/2006
Keywords:kbQFE kbfix kbBug kbExchange2003preSP2fix kbpubtypekc KB910272 kbAudITPRO