Meetings are unexpectedly moved one hour ahead in the last week of October in Exchange Server 2003 (910268)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

When you use Collaborative Data Objects (CDO) to create meetings programmatically in Microsoft Exchange Server 2003, meetings are unexpectedly moved one hour ahead in the last week of October.

CAUSE

This problem occurs when all the following conditions are true:
  • Users in your organization use e-mail clients such as Microsoft Outlook Web Access. Alternatively, users use other devices or programs that use CDO to view and to manage their calendars.
  • Your organization is configured to use the Coordinated Universal Time (UTC) time zone. (Coordinated Universal Time is also known as Greenwich Mean Time).
  • The month of October has five Sundays.
In the UTC time zone, daylight saving time starts on the last Sunday in October. However, a code defect in CDO causes the daylight saving time adjustment to occur on the fourth Sunday in October. This code defect causes an incorrect daylight saving time adjustment to occur in years that have five Sundays in October. For example, for client programs that use CDO to access meeting information, the daylight saving time adjustment occurs on October 22, 2006 instead of October 29, 2006 as expected.

Note This problem will occur next in the year 2010.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you apply the hotfix.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Cdo.dll6.5.7650.8715,77602-Dec-200518:51x86
Excdo.dll6.5.7650.83,629,05603-Dec-200510:18x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming scema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbfix kbBug kbpubtypekc KB910268 kbAudITPRO