You receive error messages when you try to send or promote an e-mail message in Microsoft CRM 3.0 (910242)



The information in this article applies to:

  • Microsoft CRM 3.0

The hotfix that is discussed in this article is not available for the Chinese version of Microsoft Dynamics CRM or for the Japanese version of Microsoft Dynamics CRM.

SYMPTOMS

When you work with an e-mail message in Microsoft CRM 3.0, you may experience the following symptoms:
  • When you send an e-mail message from Microsoft Outlook, you receive the following error message:
    An error has occurred. For more information, contact your system administrator. Do you want to send the e-mail?
  • When you promote an e-mail message in Microsoft Outlook, you receive the following error message:
    An error has occurred. For more information, contact your system administrator.
  • When you send an e-mail message from Microsoft Outlook Web Access, you receive the following error message:
    Microsoft CRM Unhandled Error Details: Server Error in '/' Application.
  • All e-mail functionality in Microsoft CRM does not work.
  • If the Dev Errors error logging process is enabled when you promote an e-mail message, you receive the following error message:
    Error Description: An Unexpected error occurred. Error Number: 0x80040216 Source File: Not Available Line Number: Not Available Request URL: http://CRM/Activities/email/edit.aspx

CAUSE

This issue may occur when the prefix value is set to null in the System Settings window. If you reset the prefix value, the e-mail functionality is not restored.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem.

To resolve this problem immediately, contact Microsoft Business Solutions Technical Support to obtain the hotfix. You can log on to the Microsoft Business Solutions Support site and create a new support request. To do this, visit the following Microsoft Web site: You can also contact Microsoft Business Solutions Technical Support by telephone at (888) 477-7877.

Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Business Solutions Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this update on computers that are running Microsoft CRM 3.0 Server.

Prerequisites

There are no prerequisites to apply this hotfix.

Removal information

To remove this hotfix from a computer that is running Microsoft Windows 2000 or Microsoft Windows Server 2003, use the Add/Remove Programs tool in Control Panel.

System administrators can use the Spunist.exe utility to remove this hotfix from a computer that is running Windows 2000 or Windows Server 2003. The Spuninst.exe utility is located in the following folder:

%Windir%\$NTUninstallKB910836$\Spuninst

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

832475 Description of the new features in the package installer for Windows software updates

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Crmmsg.dll1.2.3297.12316,08807-Sep-200519:52
Microsoft.crm.application.pages.dll3.0.5300.1005965,38401-Dec-200518:47
Mscrmcustom.dll3.0.5300.101147,45628-Oct-200522:39
Systemsettings.aspxNot Applicable33,17101-Dec-200520:09
Crmhotfix.cdfNot Applicable2,57805-Dec-200523:54
Mscrmcustom.dll3.0.5300.101147,45628-Oct-200522:39
Updspapi.dll6.1.22.0371,93607-Sep-200519:53

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MinorLast Reviewed:9/22/2006
Keywords:kbemail kberrmsg kbMBSemail kbMBSMigrate kbHotfixServer kbQFE kbpubtypekc KB910242 kbAudEndUser kbAudITPRO