Users receive a "Loading" message when they use OWA to access their mailbox after you apply a hotfix or a service pack to Exchange Server 2003 (910119)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

Consider the following scenario. You are running Microsoft Exchange Server 2003 in a front-end, back-end Outlook Web Access configuration. You apply a hotfix or a service pack to only one of the two servers. For example, you apply Exchange Server 2003 Service Pack 2 to the front-end server but not to the back-end server.

In this scenario, when users try to use Microsoft Outlook Web Access to access their mailbox by using the front-end server, Outlook Web Access is not displayed correctly. The users may receive the following message in the contents frame:Loading ...The user expects to see the mailbox message list.

CAUSE

This problem occurs if the following conditions are true:
  • You installed Exchange Server 2003 on the front-end server. Then, you installed Exchange Server 2003 Service Pack 2 without first installing Exchange Server 2003 Service Pack 1.
  • Exchange Server 2003 Service Pack 1 is installed on the back-end server.
When this occurs, the control files on the front-end server and on the back-end server are mismatched. Therefore, the Outlook Web Access interface cannot render properly in the Web browser.

RESOLUTION

To resolve this problem, apply the same updates to both the front-end and the back-end servers. We recommend that you apply the updates first to all the front-end servers, and then to the back-end servers.

For more information about how to upgrade front-end and back-end servers, view the following document on the Microsoft TechNet Web site:

WORKAROUND

To work around this issue, copy the missing update version directories from the back-end server to the front-end server. To do this, follow these steps.

Important This workaround does not replace the requirement in which you must apply updates first to front-end servers and then to back-end servers. This workaround will resolve this problem in this specific scenario.
  1. On the back-end server, start Microsoft Windows Explorer, and then locate the following folder:

    Drive_Letter:\Program Files\Exchsvr\exchweb

  2. To find the latest version of the update folder that has been created, view the contents of the exchweb folder. For example, the exchweb folder may contain the following folders:

    6.5.6944.0
    6.5.7226.0

    bin
    controls
    help
    img
    themes
    views

    In this case, the latest update version folder on the back-end server is the folder named 6.5.7226.0.
  3. On the front-end server, start Windows Explorer, and then locate the following folder:

    Drive_Letter:\Program Files\Exchsvr\exchweb

  4. View the contents of the exchweb folder. For example, this folder may display the following folders:

    6.5.6944.0
    6.5.7623.0
    bin
    controls
    help
    img
    themes
    views

  5. Copy and paste the folder named 6.5.7226.0 from the back-end server to the front-end server.
Note Perform this procedure on all front-end servers. You do not have to restart any Exchange Server services after you complete this procedure.

MORE INFORMATION

This issue only occurs with service packs or hotfixes create a new version directory under the following folder:

Drive_letter:\Program Files\exchsrvr\exchweb

A back-end server sends references that are related to the latest version under its exchweb directory in response to OWA clients. If the front-end server does not have the matching version directory, users experience the problems that are mentioned in the "Symptoms" section. This issue occurs even if the front-end server contains a newer version of the file.

Steps to reproduce the issue

  1. Install a Microsoft Exchange Server 2003 Service Pack 1 (SP1) server, and then configure this server as a back-end server.
  2. Create a user.
  3. Specify that the user's mailbox should be on the back-end server.
  4. Install an additional Exchange Server 2003 server, and then configure this server to be a front-end server. Upgrade this server Microsoft Exchange Server 2003 Service Pack 2 (SP2). Do not apply Exchange Server 2003 SP1 to this server.
  5. Use OWA to log on to the user's mailbox that you created in step 2 by using the front-end server that you configured in step 3.
  6. You experience the problems that are described in the 'Symptoms' section.

REFERENCES

For more information about the causes of the "Loading" message, click the following article number to view the article in the Microsoft Knowledge Base:

280823 Troubleshooting OWA when the contents frame displays "Loading"


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbtshoot kbprb KB910119 kbAudITPRO