Error message when you try to start Microsoft Outlook after you install the Microsoft Dynamics CRM client for Outlook: "There is a problem communicating with the Microsoft CRM Server" (910090)



The information in this article applies to:

  • Microsoft CRM client for Microsoft Office Outlook, when used with:
    • Microsoft CRM 3.0
  • Microsoft CRM 3.0

SYMPTOMS

You receive the following error message when you try to start Microsoft Outlook:
There is a problem communicating with the Microsoft CRM Server. The server might be unavailable. Try again later. If the problem persists, contact your system administrator.
If you click OK, you receive the following error message:
An error occurred loading Microsoft CRM functionality. Try restarting Microsoft Outlook. Contact your system administrator if error persists.
This issue occurs after you install the Microsoft Dynamics CRM client for Microsoft Office Outlook (the Outlook client).

CAUSE

Cause 1

This issue occurs if you used the IP address of the Microsoft Dynamics CRM server instead of the DNS name during the Outlook client installation. An example of a DNS name is http://crm.

Cause 2

This issue occurs because the user who is accessing the Outlook client is in Restricted access mode.

RESOLUTION

Resolution 1

To resolve this issue, use one of the following methods.

Method 1: Add the IP address of the Microsoft CRM server to the Trusted Sites list of the Local intranet zone on the Outlook client computer

  1. Start Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. Click the Security tab.
  4. Click Local intranet, click Sites, and then click Advanced.
  5. In the Add this Web site to the zone box, type the IP address of the Microsoft CRM server, and then click OK three times.
  6. Restart Microsoft Outlook.

Method 2: Verify that the correct URL for the Microsoft CRM server is in the ServerURL and WebAppUrl registry keys

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following subkey:

    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient

  3. Verify that the URL listed in the ServerURL and the WebAppUrl registry keys contains the correct URL for the Microsoft CRM server.

    An example of a URL in the ServerURL registry key is as follows:

    http://servername:5555/mscrmservices

    An example of a URL in the WebAPPUrl registry key is as follows:

    http://servername:5555

    Notes
    • servername is the name of the Microsoft CRM server and 5555 is the port number on which Microsoft CRM is installed.
    • If Microsoft CRM is installed on port 80, you do not need the port number listed in the registry keys.

Resolution 2

To resolve this issue, follow these steps:
  1. Start Microsoft CRM.
  2. Click Settings, click Business Unit Settings, and then click Users.
  3. Double-click the user who is experiencing this issue.
  4. In the User window, click the information side tab.
  5. Click to clear the Restricted Access Mode check box in the bottom section of the Microsoft CRM License Information.
  6. Save and close the page.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

913509 The Outlook 2003 toolbar does not appear, and you receive an error message when you start Outlook 2003 on a computer that is running Microsoft Dynamics CRM 3.0


Modification Type:MinorLast Reviewed:9/7/2006
Keywords:kberrmsg kbMBSMigrate kbprb KB910090 kbAudEndUser