Error message when you try to open a company in Small Business Accounting: "SQL Server does not exist, the service is stopped, or access is denied" (910012)



The information in this article applies to:

  • Microsoft Office Small Business Accounting 2006
  • Microsoft Office Small Business Management Edition 2006

SYMPTOMS

When you try to open a company in Microsoft Office Small Business Accounting, you may receive the following error message:
SQL Server does not exist, the service is stopped, or access is denied.

CAUSE

This issue may occur when one of the following conditions is true:
  • Users are not logged on as administrators.
  • The MSSQL$MICROSOFTSMLBIZ service is stopped.
  • TCP/IP and named pipes are not enabled.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Log on as an administrator

  1. Click Start, click Run, type %SystemRoot%\system32\compmgmt.msc /s, and then click OK.
  2. In the Computer Management window, expand Local Users and Groups, and then click Users.
  3. Verify that there is a user account created for you and that the account is a member of the Administrators group.
  4. Click Start, click Log Off, and then log on with the user account that is a member of the Administrators group.

Method 2: Start the MSSQL$MICROSOFTSMLBIZ service

The MICROSOFTSMLBIZ instance is the instance of Microsoft SQL Server Desktop Engine (MSDE) that is installed with Small Business Accounting. To start the service, follow these steps:
  1. Click Start, click Run, type services.msc, and then click OK.
  2. In the Services dialog box, right-click MSSQL$MICROSOFTSMLBIZ, and then click properties.
  3. In the MSSQL$MICROSOFTSMLBIZ Properties dialog box, click the General tab.
  4. In the Startup Type field, click Automatic.
  5. Click Start to start the MSSQL$MICROSOFTSMLBIZ service.

Method 3: Enable TCP/IP and named pipes

  1. Click Start, click Run, type svrnetcn.exe, and then click OK.
  2. In the SQL Server Network Utility dialog box, click the General tab.
  3. In the Instance(s) on this server field, click MICROSOFTSMLBIZ.
  4. In the Disabled protocols box, select Named Pipes and TCP/IP, and then click Enable.
  5. Click TCP/IP, and then click Properties.
  6. In the Default port field, type 56183, click OK, and then click Apply.
  7. Click Start, click Run, type services.msc, and then click OK.
  8. In the Services window, right-click MSSQL$MICROSOFTSMLBIZ, and then click Stop.
  9. In the Services window, right-click MSSQL$MICROSOFTSMLBIZ, and then click Start.

Modification Type:MinorLast Reviewed:12/12/2005
Keywords:kbtshoot kberrmsg kbMBSMigrate kbprb KB910012 kbAudEndUser kbAudKnowledgeWorker