FIX: The user may not be moved successfully when Profile Manager calls the "Propagate Attribute" method to move a user from one organization to a different organization in the Connected Services Framework Server 2.5 (909983)



The information in this article applies to:

  • Microsoft Connected Services Framework Server 2.5

SYMPTOMS

When Profile Manager calls the Propagate Attribute method to move a user from one organization to a different organization, the user may not be moved successfully. This problem occurs if the following conditions are true:
  • You move a user successfully from organization A to organization B.
  • The rollback flag is set to true. You try to move the same user from organization B to organization C, and the user is not moved successfully.
The rollback process moves the user to the original organization A instead of to organization B.

CAUSE

This problem occurs because of a code defect in the Propagate Attribute method of the Microsoft Connected Services Framework Server 2.5 Identity Manager. The Propagate Attribute method does not clear the OU attribute after a user is moved to a different organization.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Microsoft.csf.connector.identitymanager.dll2.5.0.1071188,41606-Oct-200500:52x86
Microsoft.csf.userorganizationchange.dll2.5.0.10717,16806-Oct-200500:52x86
Microsoft.csf.userrolechange.dll2.5.0.10715,63206-Oct-200500:53x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbfix kbBug kbQFE kbpubtypekc KB909983 kbAudDeveloper