FIX: The MSChapSrvChangePassword function may fail and may return an unexpected error code on a computer that is running Windows Server 2003 or Windows XP (909737)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Service Pack 2
  • Microsoft Windows XP Service Pack 1
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

When you call the MSChapSrvChangePassword function to change the password of a domain user account in the Active Directory directory service, the function may fail. When this problem occurs, the function may return an unexpected error code.

This problem occurs on a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP.

CAUSE

This problem occurs because the error-handling mechanism in the MSChapSrvChangePassword function implementation is incorrect.

RESOLUTION

Windows Server 2003

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites No prerequisites are required. Restart requirement You must restart the computer after you apply this hotfix. Hotfix replacement information This hotfix does not replace any other hotfixes. File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003 with Service Pack 1 (SP1), x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.25591,051,13628-Oct-200513:10x64SP1Not Applicable
Wadvapi32.dll5.2.3790.2559619,52028-Oct-200513:10x86SP1WOW
Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Advapi32.dll5.2.3790.2559619,52029-Oct-200502:46x86
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Advapi32.dll5.2.3790.434573,95229-Oct-200502:42x86
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.25591,482,24028-Oct-200513:10IA-64SP1Not Applicable
Wadvapi32.dll5.2.3790.2559619,52028-Oct-200513:10x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Advapi32.dll5.2.3790.4341,382,91228-Oct-200513:10IA-64Not Applicable
Wadvapi32.dll5.2.3790.434573,95228-Oct-200513:10x86WOW

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.Prerequisites You must have Microsoft Windows XP Service Pack 2 (SP2) or Windows XP SP1 installed to apply this hotfix. Restart requirement You must restart the computer after you apply this hotfix. Hotfix replacement information This hotfix does not replace any other hotfixes. File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Advapi32.dll5.1.2600.2792617,47209-Nov-200502:29x86
Windows XP with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Advapi32.dll5.1.2600.1771570,88009-Nov-200502:21x86SP1
Ksecdd.sys5.1.2600.177180,51209-Nov-200500:48x86SP1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbfix kbWinServ2003preSP1fix kbBug kbHotfixServer kbQFE kbpubtypekc KB909737 kbAudDeveloper