64-bit precompiled programs do not work correctly when you use Windows Compute Cluster Server 2003 in an x64 Edition version of Windows Server 2003 (909613)



The information in this article applies to:

  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 SP1
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP 64-Bit Edition Version 2003

Beta Information

This article discusses a Beta release of a Microsoft product. The information in this article is provided as-is and is subject to change without notice.

No formal product support is available from Microsoft for this Beta product. For information about how to obtain support for a Beta release, see the documentation that is included with the Beta product files, or check the Web location where you downloaded the release.

SYMPTOMS

Consider the following scenario. In an x64 Edition version of Microsoft Windows Server 2003, you use Microsoft Windows Compute Cluster Server 2003 to run one or more precompiled 64-bit programs. These precompiled programs use the Microsoft .NET Framework and Common Intermediate Language (CIL). In this scenario, the precompiled programs do not work correctly.

Note The same programs work correctly in the 32-bit versions of Windows Server 2003.

CAUSE

64-bit programs that require the .NET Framework do not work correctly if the following conditions are true:
  • These programs were compiled to use only CIL.
  • These programs were compiled to run only on architecture for a 64-bit processor.
Therefore, these programs do not work correctly in Windows Compute Cluster Server 2003. These 64-bit programs are compiled by using the /platform:x64 switch.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

The Itanium-based versions of Windows Server 2003 require Windows Server 2003 Service Pack 1 (SP1) to apply this hotfix. For more information about how to obtain Windows Server 2003 Service Pack 1 (SP1), click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.26801,638,91212-Apr-200619:53IA-64SP1SP1QFE
Wntdll.dll5.2.3790.2680762,88012-Apr-200619:53x86SP1WOW
Windows Server 2003 and Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.26801,252,35212-Apr-200619:53x64SP1SP1QFE
Wntdll.dll5.2.3790.2680762,88012-Apr-200619:53x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Windows Compute Cluster Server 2003 is a version of Windows Server 2003, Standard x64 Edition. License and software restrictions restrict the range of programs that you can run on Windows Compute Cluster Server 2003.

For more information about Windows Compute Cluster Server 2003, visit the following Microsoft Web page: For more information about the .NET services installation tool (Regsvcs.exe), visit the following Microsoft Web page: For more information about Common Intermediate Language (CIL), visit the following Microsoft Web page: To reproduce the problem that is mentioned in the "Symptoms" section, install the x64 Edition version of the .NET Framework 2.0 on a Windows Compute Cluster Server computer.

Note Make sure that Windows Computer Cluster Server is not installed together with the Compute Cluster Pack (CCP).

During the installation process, you receive a dialog box that contains an error message. This error message reports a problem with the Windows Installer package at the time of installation. When you receive this error message, an event that is similar to the following will be logged in the Application log:Event ID: 10005 Source: MsInstaller Description: Product: Microsoft .NET Framework 2.0 Beta (x64) - There is a problem with this Windows Installer Package. Please refer to the setup log for more information.This error message is generated by the .NET services installation tool (RegSvcs.exe). In the error message dialog box, you have the option to click either Retry or Cancel. Click Cancel to let the installation process finish. For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinXP64Bit2003sp1fix kbWinServ2003SP1fix kbBug kbfix kbpubtypekc KB909613 kbAudITPRO