The screen may appear black or green during playback when the Windows Media Player control is embedded in a Web page (909554)



The information in this article applies to:

  • Microsoft Windows Media Player 10
  • Microsoft Windows Media Player 9 Series for Windows XP
  • Microsoft Windows Media Player 9 Series for Windows Server 2003

SYMPTOMS

When the Microsoft Windows Media Player control is embedded in an application such as a Web page, the audio may play back correctly during playback of content, but the video may not play back as expected. The screen may appear black or green.

CAUSE

Black screen issues and green screen issues generally occur because of an outdated or incompatible video driver. However, the possible causes of these issues are not limited to the video driver.

RESOLUTION

To resolve this issue, use one or more of the following methods:
  • Make sure that you are using the latest drivers for the video card that are provided directly from the video card manufacturer or from the system manufacturer. If you update the drivers, make sure that the Color Quality setting in the Display Properties dialog box was not reset.
  • Verify that you have any other software updates for the video card. Also, verify that you have the latest updates for Microsoft DirectX. For other software updates for the video card, and also for DirectX updates, visit the following Microsoft Web site:
  • Turn down video acceleration. To do this in Microsoft Windows Media Player 9 Series or in later versions of Microsoft Windows Media Player, follow these steps:
    1. On the Tools menu, click Options. The Options dialog box appears.
    2. In the Options dialog box, click the Performance tab.
    3. In the Video acceleration area, move the slider to turn down or turn off video acceleration.
    4. Test to see whether the video will play back correctly.
    If the video still does not play back correctly, repeat steps 3 and 4. Move the slider down until the issue no longer occurs.
  • Change the advanced video acceleration settings. To do this in Windows Media Player 9 Series or in later versions of Windows Media Player, follow these steps:
    1. On the Tools menu, click Options. The Options dialog box appears.
    2. In the Options dialog box, click the Performance tab.
    3. In the Video acceleration area, click Advanced.
    4. In the Video Acceleration Settings dialog box, click to clear the check box for Use Overlays.
    5. Test to see whether the video will play back correctly. If the video does not play back correctly, and you are using Windows Media Player 10, go to step 6.
    6. In the Video Acceleration Settings dialog box, click to clear the check box for Use High Quality Mode.
    7. Test to see whether the video will play back correctly.
  • Lower the screen resolution. To do this, follow these steps:
    1. Right-click the Microsoft Windows desktop, and then click Properties.
    2. In the Display Properties dialog box, click the Settings tab.
    3. In the Screen Resolution section, drag the slider to incrementally decrease the screen resolution.
    4. Test to see whether the video will play back correctly.

STATUS

This behavior is by design.

MORE INFORMATION

The following methods make some advanced configuration changes. These changes may also resolve the issue.
  • Turn off the Plug and Play setting in the BIOS. This change forces Windows to assign resources differently. Sometimes, this change resolves the issue. See the system documentation or contact the manufacturer of the system if you are not sure how to perform this task.
  • You may have to determine whether the video hardware is equipped with other utilities which will let you control the Overlay settings. See the system documentation or contact the manufacturer of the system if you are not sure how to perform this task.
  • Sometimes, changing the rate that the video card updates the screen will correct graphics problems. The settings and methods to change this rate may vary greatly depending on the system hardware. See the system documentation or contact the manufacturer of the system if you are not sure how to perform this task.
  • DirectX may be detecting an older video card that is no longer installed. See the system documentation or contact the manufacturer of the system to determine the steps that are required to make sure that DirectX is detecting the correct video card.
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/22/2005
Keywords:kbprb KB909554 kbAudDeveloper kbAudITPRO kbAudEndUser