The Microsoft CRM 1.2 Web client may stop responding, and then the Microsoft CRM 1.2 server may stop responding, when a user tries to run Microsoft CRM Sales for Outlook (909443)



The information in this article applies to:

  • Microsoft Business Solutions CRM Sales for Outlook, when used with:
    • Microsoft CRM 1.2
  • Microsoft CRM 1.2

SYMPTOMS

When a user tries to run Microsoft Business Solutions CRM Sales for Outlook (the Outlook client), the Microsoft CRM 1.2 Web client on the client computer may stop responding. As a result, the Microsoft CRM 1.2 server may stop responding.

CAUSE

This problem may occur if the user is a member of many groups in the Active Directory directory service. Because of the many interactions between the Microsoft CRM client and Microsoft Internet Information Services (IIS) to resolve the groups, heap corruption occurs in the IIS process (W3wp.exe). Therefore, IIS cannot send back the initialization information to the Microsoft CRM 1.2 client. If the user ends the Outlook process and repeats the Outlook client Offline process several times, IIS will no longer have available threads. Therefore, IIS stops serving pages for the Microsoft CRM application pool. IIS must then be reset.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next version of Microsoft CRM that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Installation information

Install this hotfix on computers that are running Microsoft CRM 1.2 server.

Prerequisites

There are no prerequisites to install this hotfix.

Removal information

You cannot remove this hotfix.

Restart requirement

If you are prompted, restart the computer after you install the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTime
Addfields.aspxNot Applicable8,68029-Sep-200515:22
Crmmsg.dll1.2.3297.12316,08807-Sep-200519:52
Crmsecurity.dll1.2.3297.203158,43219-Oct-200521:42
Field-memo.aspxNot Applicable9,37629-Sep-200515:22
Field-number.aspxNot Applicable11,47419-Oct-200519:18
Kb888331.dll1.2.3297.10610,97619-Oct-200521:37
Kb892352.dll1.2.3297.10510,97619-Oct-200521:37
Kb898055.dll1.2.3297.10310,97619-Oct-200520:37
Kb909443.dll1.2.3297.10110,97619-Oct-200521:37
Mscrmcustom.dll1.2.3297.204121,56807-Sep-200519:52
Publish.xmlNot Applicable12,12319-Oct-200519:18
Crmsecurity.dll1.2.3297.203158,43219-Oct-200521:42
Crmhotfix.cdfNot Applicable4,21520-Oct-200520:31
Mscrmcustom.dll1.2.3297.204121,56807-Sep-200519:52
Updspapi.dll6.1.22.0371,93607-Sep-200518:53

SYMPTOMS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used to describe Microsoft software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

887283 Microsoft Business Solutions CRM software hotfix and update package naming standards


Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kbstoprespond kbMBSMigrate kbQFE kbHotfixServer kbpubtypekc KB909443 kbAudEndUser