FIX: In Control Panel, "Sounds and Audio Devices" does not correctly display the setting in the "Speaker Setup" list (909441)



The information in this article applies to:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

SYMPTOMS

After an application calls the Microsoft DirectSound SetSpeakerConfig method and specifies either the DSSPEAKER_7POINT1_SURROUND value or the DSSPEAKER_7POINT1_WIDE value, Sounds and Audio Devices in Control Panel does not correctly display the setting in the Speaker Setup list.

If an application specifies the DSSPEAKER_7POINT1_SURROUND value, Sounds and Audio Devices should display the description 7.1 home theater speakers. Instead, Sounds and Audio Devices incorrectly displays the description 7.1 wide configuration speakers.

If an application specifies the DSSPEAKER_7POINT1_WIDE value, Sounds and Audio Devices should display the description 7.1 wide configuration speakers. Instead, Sounds and Audio Devices incorrectly displays the description 7.1 home theater speakers.

CAUSE

This problem occurs because the DSSPEAKER_7POINT1_SURROUND value and the DSSPEAKER_7POINT1_WIDE value are mapped incorrectly when Control Panel is initialized in Microsoft Windows XP.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following file is available for download from the Microsoft Download Center:

DownloadDownload the WindowsXP-KB909441-x86-ENU.exe package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTime
Mmsys.cpl5.1.2600.2776618,49614-Oct-200501:50

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbfix kbQFE kbHotfixServer KB909441 kbAudDeveloper kbAudEndUser kbAudOEM