IMAP4 clients are disconnected when they try to retrieve a message by using the FETCH BODYSTRUCTURE IMAP4 command in Exchange Server 2003 (909358)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

When IMAP4 clients that connect through a front-end server that is running Microsoft Exchange Server 2003 try to retrieve a message by using the FETCH BODYSTRUCTURE IMAP4 command, the clients are disconnected.

CAUSE

This problem may occur when the message contains corrupted or malformed MIME code.

RESOLUTION

Hotfix information

Apply this hotfix on the back-end Exchange Server 2003 server. A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, you must have Microsoft Exchange Server 2003 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You must restart Exchange Server 2003 and the Internet Information Services service on the back-end server after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Eximap4.dll6.5.7233.6482,94416-Dec-200503:27x86
Expop3.dll6.5.7233.6422,01616-Dec-200503:27x86
Exproto.dll6.5.7233.6426,11216-Dec-200503:28x86
Febecfg.dll6.5.7233.6427,64816-Dec-200502:48x86
Iisif.dll6.5.7233.6423,04016-Dec-200503:27x86
Iisproto.dll6.5.7233.64133,63216-Dec-200503:29x86
Imap4be.dll6.5.7233.6456,83216-Dec-200503:29x86
Imap4fe.dll6.5.7233.64122,88016-Dec-200502:49x86
Imap4svc.dll6.5.7233.64119,29616-Dec-200503:27x86
Pop3be.dll6.5.7233.6427,13616-Dec-200503:27x86
Pop3fe.dll6.5.7233.6412,28816-Dec-200502:50x86
Pop3svc.dll6.5.7233.6469,12016-Dec-200503:24x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbfix kbBug kbExchange2003preSP2fix kbpubtypekc KB909358 kbAudITPRO