You may not receive any results when you perform a filtered name search in the WINS management tool in Windows Server 2003 or in Windows XP (909195)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional x64 Edition

SYMPTOMS

On a computer that is running Microsoft Windows Server 2003 or Microsoft Windows XP, you may not receive any results when you perform a filtered name search in the Windows Internet Name Service (WINS) management tool. Or, you may receive unexpected results. This problem occurs even though results that match your query exist in the database.

CAUSE

This problem occurs because a problem in the WINS management tool prevents results from being returned for some searches.

RESOLUTION

Windows Server 2003

This hotfix will prompt the user for the location to which to extract the file. The default location is %windir%\system32.

Note The %windir% placeholder represents the folder that contains the Windows operating system files. For example, the default location may be C:\Windows\system32.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesTo apply this hotfix, you must have Windows Server 2003 Service Pack 1 installed.Restart requirementYou do not have to restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Winssnap.dll5.2.3790.26311,151,48802-Feb-200619:08x64Not Applicable
Wwinssnap.dll5.2.3790.2631651,77602-Feb-200619:08x86WOW


Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Winssnap.dll5.2.3790.26312,042,36802-Feb-200619:08IA-64Not Applicable
Wwinssnap.dll5.2.3790.2631651,77602-Feb-200619:08x86WOW


Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Winssnap.dll5.2.3790.2631651,77602-Feb-200619:07x86

Windows XP

This hotfix will prompt the user for the location to which to extract the file. The default location is %windir%\system32.

Note The %windir% placeholder represents the folder that contains the Windows operating system files. For example, the default location may be C:\Windows\system32.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesThere are no prerequisites to apply this hotfix.Restart requirementYou do not have to restart the computer after you apply this hotfix.Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows XP
File nameFile versionFile sizeDateTimePlatform
Winssnap.dll5.2.3790.2631651,77602-Feb-200619:07x86


Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatformService branch
Winssnap.dll5.2.3790.26311,151,48802-Feb-200619:08x64Not Applicable
Wwinssnap.dll5.2.3790.2631651,77602-Feb-200619:08x86WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbBug kbfix kbQFE kbpubtypekc KB909195 kbAudITPRO