The computer occasionally does not hibernate and you receive an "Insufficient System Resources Exist to Complete the API" error message in Windows XP with Service Pack 2, in Windows XP Tablet PC Edition 2005, or in Windows XP Media Center Edition 2005 (909095)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition 2005
  • Microsoft Windows XP Tablet PC Edition 2005

SYMPTOMS

You use a computer that is running Microsoft Windows XP with Service Pack 2 (SP2), Microsoft Windows XP Tablet PC Edition 2005, or Microsoft Windows XP Media Center Edition 2005. When you try to put the computer in hibernation, the computer occasionally does not hibernate. When this problem occurs, you receive an error message that is similar to the following:
Insufficient System Resources Exist to Complete the API.
When you experience this problem, the hibernate feature is not available on the computer until you restart the computer.

This problem typically occurs when the computer uses 1 gigabyte (GB) or more of RAM.

Note The Windows XP SP2 features and components are included in Windows XP Tablet PC Edition 2005 and in Windows XP Media Center Edition 2005.

CAUSE

This problem occurs because the Windows kernel power manager cannot obtain the memory resources that are required to prepare the computer to hibernate.

RESOLUTION

Update information

The following file is available for download from the Microsoft Download Center:

DownloadDownload the Update for Windows XP (KB909095) package now.

Release Date: August 15, 2006

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Hotfix information

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.1.2600.27742,136,06412-Oct-200500:18x86SP2SP2QFE
Ntkrnlpa.exe5.1.2600.27742,057,34411-Oct-200523:54x86SP2SP2QFE
Ntkrpamp.exe5.1.2600.27742,015,23211-Oct-200523:54x86SP2SP2QFE
Ntoskrnl.exe5.1.2600.27742,180,09612-Oct-200500:20x86SP2SP2QFE

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To prepare the computer to hibernate, the Windows kernel power manager requires a block of contiguous memory. The size of this contiguous memory is proportional to the number of physical memory regions that the computer is using. A computer that uses lots of RAM is likely to use more physical memory regions when the computer prepares to hibernate. Therefore, a larger amount of contiguous memory is required to prepare the computer to hibernate.

Additionally, the number of physical memory regions varies according to the programs, services, and device drivers that the computer uses. Therefore, the hibernate feature occasionally fails.

When the Windows kernel power manager detects that the hibernate feature has failed, the hibernate feature remains disabled until you restart the computer.

For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:8/16/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug kbpubtypekc KB909095 kbAudITPRO