A meeting request acceptance message from a Lotus Notes user generates an NDR, and the acceptance message is stuck in the local delivery queue in Exchange Server 2003 (909068)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Service Pack 2
  • Microsoft Exchange Server 2003 Enterprise Edition, Service Pack 1 (SP-1)
  • Microsoft Exchange Server 2003 Standard Edition, Service Pack 1 (SP1)

SYMPTOMS

Consider the following scenario. A Microsoft Outlook user forwards a meeting request to a Lotus Notes user. When the Lotus Notes user accepts the meeting request, an e-mail message is sent to the originator of the meeting request. However, the acceptance message never reaches the recipient. The Lotus Notes user receives a non-delivery report (NDR) message. Additionally, the acceptance message of the Lotus Notes user is stuck in the local delivery queue of the Microsoft Exchange Server 2003 server that hosts the mailbox of the recipient. The following event is logged in the Application log:Event ID: 327
Event Type: Warning
Event Source: MSExchangeTransport
Event Category: Exchange Store Driver
Date: Date
Time: Time
User: Not applicable
Computer: Computer_Name
Description: The following call : EcSetFileHandleProp to the store failed. Error code : -2147417836. MDB : b8ef8c9e-2fe0-4ecc-be8d-e8d00030fe10. FID : . MID : . File : Q:\Exchsrvr\Mailroot\vsi 1

CAUSE

The message is not delivered if the Lotus Notes user's meeting request acceptance message contains an empty Attendee:mailto field.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Hotfix installation information

The message will be delivered correctly if the Attendee:mailto field in the message is populated by the sending program. However, after you apply the hotfix, non-delivered messages are deleted from the local delivery queue, as expected.

Microsoft Exchange Server 2003 SP1

Prerequisites You must install Microsoft Exchange Server 2003 Service Pack 1 (SP1) before you apply the hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement You do not have to restart the computer after you apply the hotfix. However, the Microsoft Exchange Information Store service and all dependent services will be restarted.Hotfix replacement information This hotfix does not replace any other hotfixes.File information The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Excdo.dll6.5.7233.593,648,00023-Nov-200503:51x86
Mdbmsg.dll6.5.7233.593,270,14423-Nov-200503:50x86
Redir.aspNot applicable3,30404-Jun-200501:56Not applicable
Store.exe6.5.7233.595,201,40823-Nov-200517:08x86

Microsoft Exchange Server 2003 SP2

Prerequisites You must install Microsoft Exchange Server 2003 Service Pack 2 (SP2) before you apply the hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement You do not have to restart the computer after you apply the hotfix.Hotfix replacement information This hotfix does not replace any other hotfixes.File information
File nameFile versionFile sizeDateTimePlatform
Excdo.dll6.5.7650.143,629,05620-Dec-200505:17x86
The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages



The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbExchange2003sp1fix kbQFE kbfix kbBug kbpubtypekc KB909068 kbAudITPRO