You experience intermittent authentication errors when you use Authorization Manager together with an Active Directory-based role store in Windows Server 2003 (908757)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition

SYMPTOMS

When you use Microsoft Windows Server 2003 Authorization Manager together with an Active Directory-based role store, you experience intermittent authentication errors. You typically experience this problem when the server is under a heavy load.

CAUSE

When Authorization Manager is used together with an Active Directory-based role store, Authorization Manager incorrectly creates an auditing thread for every application in the store. You expect Authorization Manager to create an auditing thread only for the application that is referenced in the AzAuthorizationStore.CreateApplication method.

If many applications are defined in a store, lots of threads may be created. Therefore, you may experience high resource usage and decreased performance when you use Authorization Manager in this situation. You experience this problem more acutely if you use Authorization Manager in a Microsoft Internet Information Services (IIS) application. For example, consider the following scenario:
  • You have n number of applications defined in a store.
  • You have m number of IIS applications that use these defined applications.
In this scenario, the number of auditing threads that Authorization Manager creates is equal to m*n.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must be running Windows Server 2003 Service Pack 1 (SP1) to apply this hotfix.

Restart requirement

Generally, you do not have to restart the computer after you apply this hotfix. However, if the Azroles.dll file is being used when you apply this hotfix, you must restart the computer.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based 32-bit editions
File nameFile versionFile sizeDateTimePlatform
Azroles.dll5.2.3790.2605232,44830-Dec-200518:41x86
Windows Server 2003, x64-based 64-bit editions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.2605414,20830-Dec-200517:57x64SP1SP1QFE
Wazroles.dll5.2.3790.2605232,44830-Dec-200517:57x86SP1WOW
Windows Server 2003, IA64-based 64-bit editions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Azroles.dll5.2.3790.2605703,48830-Dec-200517:57IA-64SP1SP1QFE
Wazroles.dll5.2.3790.2605232,44830-Dec-200517:57x86SP1WOW

WORKAROUND

To work around this problem, use Authorization Manager together with an XML-based store.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinServ2003preSP2fix kbHotfixServer kbBug kbfix kbQFE kbpubtypekc KB908757 kbAudITPRO