Web proxy clients cannot access some Web sites through ISA Server 2004 (908501)



The information in this article applies to:

  • Microsoft Internet Security and Acceleration Server 2004, Standard Edition

SYMPTOMS

Web proxy clients cannot access some Web sites through Microsoft Internet Security and Acceleration (ISA) Server 2004.

CAUSE

This problem occurs when all the following conditions are true:
  • A Deny rule is configured in ISA Server 2004 to apply to some content type and to all users.
  • An Allow rule that has a lower priority than the Deny rule is configured to apply to some user groups.
  • The ISA Server 2004 cache is enabled.
  • You try to access an external site that is cached on the ISA Server 2004 computer.
In this scenario, ISA Server 2004 resets the connection during authentication.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Internet Security and Acceleration Server 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

891024 How to obtain the latest ISA Server 2004 service pack

Hotfix Information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft ISA Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
W3filter.dll4.0.2163.281661,21627-Sep-200516:15x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Internet Security and Acceleration Server 2004 Service Pack 2.

MORE INFORMATION

For more information about the terms that are used to describe software updates, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages

For more information about how to install ISA Server 2004 hotfixes and updates, click the following article number to view the article in the Microsoft Knowledge Base:

885957 How to install ISA Server hotfixes and updates


Modification Type:MinorLast Reviewed:10/12/2006
Keywords:kbQFE kbfix kbBug kbHotfixServer kbpubtypekc KB908501 kbAudITPRO