After you install support files for East Asian languages on a computer that is running Windows Server 2003, applications may not allocate sufficient memory (908132)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

SYMPTOMS

After you install support files for East Asian languages on a computer that is running Microsoft Windows Server 2003, applications that require lots of contiguous memory may not allocate sufficient memory. Every application that tries to allocate lots of contiguous memory may handle this problem differently. Some applications fail, and some applications silently recover. For example, you may experience this problem when SAP software cannot start successfully.

CAUSE

This problem occurs if the load address of the Lpk.dll file has fragmented the user mode address space. This event causes a base address conflict. The Lpk.dll file is loaded when you install support files for East Asian languages.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows Server 2003 Service Pack 1 (SP1) installed.

Note x64-based versions of Windows Server 2003 include SP1.

Restart requirement

You must restart the computer after you apply the hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Lpk.dll5.2.3790.253368,60821-Sep-200523:50IA-64SP1Not Applicable
Wlpk.dll5.2.3790.253322,01621-Sep-200523:50x86SP1WOW

Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Lpk.dll5.2.3790.253322,01622-Sep-200501:22x86

Windows Server 2003 with SP1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Lpk.dll5.2.3790.253335,84021-Sep-200523:50x64SP1Not Applicable
Wlpk.dll5.2.3790.253322,01621-Sep-200523:50x86SP1WOW

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbWinServ2003preSP1fix kbfix kbBug kbHotfixServer kbQFE kbpubtypekc KB908132 kbAudEndUser kbAudGeneralUser