Intermittent memory corruption occurs in the binary data that is stored on a compressed NTFS file system drive on a Windows XP-based computer (907870)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
  • Microsoft Windows XP Service Pack 1, when used with:
    • Microsoft Windows XP Professional

SYMPTOMS

Intermittent memory corruption occurs in the binary data that is stored on a compressed NTFS file system drive on a Windows XP-based computer. The computer cannot run programs that use this binary data.

CAUSE

This problem occurs because of a code defect in the Ntfs.sys file.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 1 (SP1) or Service Pack 2 (SP2) installed on the computer. For more information about how to obtain Windows XP SP1 or SP2, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntfs.sys5.1.2600.1779562,04829-Nov-200501:17x86SP1SP1QFE
Ntfs.sys5.1.2600.2803574,97629-Nov-200501:19x86SP2SP2QFE

WORKAROUND

To work around this problem, do not use NTFS drive compression.

MORE INFORMATION

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbWinXPsp1fix kbBug kbfix kbpubtypekc KB907870 kbAudEndUser kbAudITPRO