Outlook Web Access users cannot access a URL in a plain text e-mail message (907867)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

SYMPTOMS

After you apply hotfix 890059 to Microsoft Exchange Server 2003, Outlook Web Access users cannot access a URL in a plain text e-mail message when they click the URL in the body of the message. This problem occurs when the following conditions are true:
  • The URL contains Traditional Chinese, Simplified Chinese, Japanese, or Korean characters. These characters are also known as double-byte character set (DBCS) characters.
  • The URL does not start with the fully qualified domain name (FQDN) of the server. For example, the following URL should be the URL for a server that is named Server1 in a domain that is named Domain1.com:

    http://server1.domain1.com

    The Outlook Web Access user cannot access the URL if it is entered in a different format. For example, the user cannot access the URL if it is entered as follows:

    http://server1

CAUSE

This problem occurs when the DBCS characters in the URL are unnecessarily converted to UTF-8 characters when Outlook Web Access retrieves the HTML message from the Exchange store. Therefore, the URL is corrupted.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must install Microsoft Exchange Server 2003 Service Pack 1 (SP1), before you apply the hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix. However, the Microsoft Exchange Information Store service and all other dependant services will be restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.5.7233.563,270,14405-Nov-200503:05x86
Redir.aspNot applicable3,30404-Jun-200501:56Not applicable
Store.exe6.5.7233.565,201,40805-Nov-200503:39x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

817903 New naming schema for Exchange Server software update packages


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbfix kbBug kbpubtypekc KB907867 kbAudITPRO