A Windows XP-based client computer may leak memory when the Remote Desktop utility is configured to connect serial port devices to the host computer (907572)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 1, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition

SYMPTOMS

Consider the following scenario:
  • You use the Remote Desktop utility (Mstsc.exe) on a Microsoft Windows XP-based client computer to connect to a Microsoft Windows Server 2003-based host computer.
  • On the Local Resources tab of the Remote Desktop Connection dialog box, you select Serial ports under Connect automatically to these local devices when logged on to the remote computer.
In this scenario, the client computer may leak memory when the serial port receives data.

CAUSE

This problem occurs when the Remote Desktop utility is configured to connect serial port devices to the host computer. In this configuration, the host computer assumes that the serial port devices are connected to a local serial port on the host computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows XP with Service Pack 1
   Date         Time   Version           Size     File name
   --------------------------------------------------------------
   09-Sep-2005  03:58  5.1.2600.1743     599,040  Mstscax.dll      
   
Windows XP with Service Pack 2
   Date         Time   Version           Size     File name
   -------------------------------------------------------------- 
   09-Sep-2005  04:03  5.1.2600.2756     655,872  Mstscax.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp3fix kbWinXPpreSP3fix kbfix kbbug kbpubtypekc KB907572 kbAudITPRO