The computer may stop responding after you install hotfix 839406, security update 896422, or Update Rollup 1 for Windows 2000 SP4 on a Windows 2000-based computer (907404)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional



Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

After you install hotfix 839406, security update 896422, or Update Rollup 1 for Windows 2000 Service Pack 4 (SP4) on a Microsoft Windows 2000-based file server, the computer may stop responding when you copy many large files to the computer. For more information about hotfix 839406, click the following article number to view the article in the Microsoft Knowledge Base:

839406 Write operations to a shared folder on a Windows 2000-based computer over a Fibre Channel connection is slower than expected

For more information about security update 896422, click the following article number to view the article in the Microsoft Knowledge Base:

896422 MS05-027: Vulnerability in Server Message Block could allow remote code execution

Note Security update 896422 was issued in security bulletin MS05-027. For more information about Update Rollup 1 for Windows 2000 SP4, click the following article number to view the article in the Microsoft Knowledge Base:

891861 Update Rollup 1 for Windows 2000 SP4 and known issues

CAUSE

This problem occurs because of the performance enhancement that was introduced in hotfix 839406. This performance enhancement improves the throughput for large writes to a Windows 2000 file server. This performance enhancement bypasses the throttling mechanism that is built into the cache manager.

If the disk subsystem is slower than the network interface, the cache manager buffers the difference in throughput. When large writes are sustained and when the disk subsystem is much slower than the network interface, the cache can become consumed with pending writes to the disk. Other crucial writes may be deferred until the cache manager can copy enough of the cached data from the large files to disk. Because large writes are no longer throttled because of the performance enhancement in hotfix 839406, other crucial writes may be deferred until the large writes stop and the disk subsystem can catch up. When these crucial writes are deferred, the computer stops responding.

Note As soon as the large writes are completed and the disk subsystem catches up, the computer will return to ordinary operation.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 839406 and security update 896422.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size  File name
   ------------------------------------------------------
   19-Sep-2005  12:57  5.0.2195.7071  239,088  Srv.sys
   19-Sep-2005  21:35  5.0.2195.6930   76,048  Srvsvc.dll

Installation instructions

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you apply this hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate to the following subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\

    .
  3. Right-click the right pane, point to New, and then click DWORD Value.
  4. Type DisableLargeMdlW, and then press ENTER.
  5. Double-click DisableLargeMdlW, type 1 in the Value data box, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbpubtypekc KB907404 kbAudDeveloper kbAudITPRO