FIX: An access violation occurs in the Mshtml.dll navigation component when you try to browse a Web application that uses HTML Component (HTC) files in Internet Explorer 6 (907338)



The information in this article applies to:

  • Microsoft Internet Explorer (Programming) 6 (SP1), when used with:
    • Microsoft Windows XP Service Pack 2
    • Microsoft Windows XP Service Pack 1

SYMPTOMS

In Microsoft Internet Explorer 6, when you try to browse a Web application that uses HTML Component (HTC) files, an access violation occurs in the Mshtml.dll navigation component. Additionally, Internet Explorer 6 closes. This problem occurs when the Web application uses dynamic HTML (DHTML) behaviors and HTC files extensively.

Note This problem does not occur when you click Every visit to the page under Check for newer versions of stored pages in Internet Explorer 6.

CAUSE

This problem occurs when you use the Mshtml.dll navigation component for HTC files in Internet Explorer 6.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Microsoft Windows XP Service Pack 2 (SP2)
File nameFile versionFile sizeDateTimePlatform
Browseui.dll6.0.2900.28381,022,97601-Feb-200606:18x86
Iepeers.dll6.0.2900.2838251,90401-Feb-200606:18x86
Mshtml.dll6.0.2900.28383,073,02401-Feb-200606:18x86
Shdocvw.dll6.0.2900.28381,495,04001-Feb-200606:18x86
Shlwapi.dll6.0.2900.2838474,11201-Feb-200606:18x86
Urlmon.dll6.0.2900.2838613,37601-Feb-200606:18x86
Microsoft Windows XP Service Pack 1 (SP1)
File nameFile versionFile sizeDateTimePlatform
Mshtml.dll6.0.2800.15322,706,94426-Jan-200622:23x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about HTC files, visit the following Microsoft Developer Network (MSDN) Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbHotfixServer kbQFE kbpubtypekc KB907338 kbAudITPRO kbAudDeveloper