The Microsoft Exchange Information Store service stops responding in Exchange Server 2003 and a Dr. Watson access violation error is generated in the EcParseTransferSD function (907318)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition

SYMPTOMS

In Microsoft Exchange Server 2003, the Microsoft Exchange Information Store service (Store.exe) stops responding. Additionally, a Dr. Watson access violation error is generated in the EcParseTransferSD function if the following conditions are true:
  • Dr. Watson is enabled.
  • Symbols are installed.

CAUSE

This problem occurs if the following conditions are true:
  • The PR_NT_SECURITY_DESCRIPTOR property is set to "null."
  • The PR_NT_SECURITY_DESCRIPTOR property is passed to the EcParseTransferSD function.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Exchange Server 2003. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 1.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you install the hotfix. However, the Microsoft Exchange Information Store service and all dependent services will be restarted.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Mdbmsg.dll6.5.7233.503,270,14429-Sep-200501:55x86
Redir.aspNot applicable3,30404-Jun-200501:56Not applicable
Store.exe6.5.7233.505,182,46429-Sep-200502:30x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:7/26/2006
Keywords:kbexchSTORE kbQFE kbfix kbBug kbExchange2003preSP2fix kbpubtypekc KB907318 kbAudITPRO