BUG: You may receive an error message when you upgrade from SQL Server 2005 Developer Edition to SQL Server 2005 Enterprise Edition (907241)



The information in this article applies to:

  • Microsoft SQL Server 2005 Developer Edition Community Technology Preview
  • Microsoft SQL Server 2005 Developer Edition for Itanium-based Systems Community Technology Preview
  • Microsoft SQL Server 2005 Developer x64 Edition Community Technology Preview
  • Microsoft SQL Server 2005 Enterprise Edition Community Technology Preview

SYMPTOMS

When you try to upgrade from Microsoft SQL Server 2005 Developer Edition to SQL Server 2005 Enterprise Edition, you may receive the following error message from full text crawls and queries:
Error: 0x80070426(The service has not been started.).
The full text service logs may contain the following warning message:
Warning: Failed to get MSFTESQL indexer interface for full-text catalog 'cat1' ('5') in database 'fulltext_test_nondefault' ('6').
This problem occurs if you change the SQL Server service account after you install SQL Server 2005 Developer Edition but before you install SQL Server 2005 Enterprise Edition.

CAUSE

When you install SQL Server 2005 Developer Edition, the MSFTESQL service account and the SQL Server service account are the same. When you set the launch permissions on the MSFTESQL APPID to let SQL Server start the MSFTESQL service, the launch permissions are set by using the MSFTESQL service account. After the SQL service account is changed from the MSFTESQL service account, the two accounts are no longer the same. Because the accounts are not the same, the launch permissions are set incorrectly to the MSFTSQL service account when you upgrade from SQL Server 2005 Developer Edition to SQL Server 2005 Enterprise Edition. The incorrect launch permissions prevent SQL Server from starting the service, and you receive the error message.

WORKAROUND

To work around this problem, modify the launch permissions of the MSFTESQL APPID to include the new SQL Server account or group. To do this, follow these steps:
  1. Locate the APPID for the upgraded MSFTESQL instance. To do this, follow these steps:
    1. Click Start, click Run, and then enter regedit.
    2. Locate the HKLM\Software\Microsoft\MSFTESQLInstMap registry key.
    3. Find the subkey with a FriendlyName value that corresponds to the instance that was upgraded.
    4. Copy the APPID key for the subkey that corresponds to the instance that you upgraded to SQL Server 2005 Enterprise Edition.
  2. Locate the current service account of the upgraded instance of SQL Server. To do this, follow these steps:
    1. Click Start, click Run, and then enter MMC to open the Microsoft Management Console (MMC).
    2. Click File, and then click Add/Remove Snapin to add the Services snap-in.
    3. Locate the instance of SQL Server that you upgraded, and then double-click the instance.
    4. Click the Log On tab, and then copy the account name under which this instance is running.
  3. Update the launch permissions for the instance of MSFTESQL. To do this, follow these steps:
    1. Click Start, click Run, and then enter MMC.
    2. Click File, and then click Add/Remove Snapin to add the Component Services snap-in.
    3. Expand Component Services, expand Computers, expand My Computer, and then expand DCOM Config.
    4. Right-click the entry that corresponds to the APPID that you located in step 1, and then click Properties.
    5. Click the Security tab
    6. Under Launch and Activation Permissions, click Customize, and then click Edit.
    7. Add the account that you located in step 2, and then grant Local Launch permissions and Local Activation permissions to the account.

      Note You can also remove the incorrect account that corresponds to the current service account of the upgraded MSFTSQL instance.
    8. Click Apply.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:1/11/2006
Keywords:kbsql2005cluster kbsql2005setup kbbug KB907241 kbAudDeveloper kbAudITPRO