Virtual PC 2004 stops responding if you press the "at" key (@) when you switch to a virtual machine on a computer that is running the Japanese version of Windows XP (906870)



The information in this article applies to:

  • Microsoft Virtual PC 2004
  • Microsoft Virtual PC 2004 Service Pack 1

SYMPTOMS

If you press the "at" key (@) when you switch to a Microsoft Virtual PC 2004 virtual machine on a computer that is running the Japanese version of Microsoft Windows XP, Virtual PC 2004 may stop responding.

CAUSE

This problem occurs because of a bug in Virtual PC 2004 that prevents it from correctly handling the "at" keystroke.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Virtual PC 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
AdditionsisoNot Applicable27,011,07208-Nov-200506:04Not Applicable
PrecompactorNot Applicable2,254,84808-Nov-200506:04Not Applicable
Updatedapp5.3.582.394,004,56808-Nov-200506:04Not Applicable
Updvmm1.1.465.14152,29608-Nov-200506:04Not Applicable
Vpcapp5.3.582.274,000,46408-Nov-200506:04Not Applicable

WORKAROUND

To work around this problem, switch to the English keyboard layout driver on the host operating system. To do this, follow these steps:
  1. If the problem has already occurred, follow these steps:
    1. Close all guest operating systems.
    2. Exit Virtual PC 2004, and then restart Virtual PC 2004.
    If the problem has not already occurred, go to step 2.
  2. Click Start, click Run, type intl.cpl, and then click OK.
  3. On the Languages tab, click Details, and then change the keyboard layout driver to the English version.
  4. Exit Virtual PC 2004, and then restart Virtual PC 2004.

Modification Type:MajorLast Reviewed:2/10/2006
Keywords:kbfix kbBug kbQFE KB906870 kbAudEndUser kbAudITPRO