FIX: Visual Studio 2005 may unexpectedly quit when you try to view MSDN documentation or when you try to create a new Visual C++ project on Windows XP Service Pack 2 (906673)



The information in this article applies to:

  • Microsoft Visual Studio 2005 Standard Edition
  • Microsoft Visual Studio 2005 Professional Edition
  • Microsoft Visual Studio 2005 Express Edition
  • Microsoft Visual Studio 2005 Team System Architect Edition
  • Microsoft Visual Studio 2005 Team System Developer Edition
  • Microsoft Visual Studio 2005 Team System Team Foundation:
  • Microsoft Visual Studio 2005 Team System Test Edition
  • Microsoft Developer Network (MSDN), when used with:
    • Microsoft Windows XP Professional SP2
    • Microsoft Windows XP Home Edition SP2

SYMPTOMS

On a computer that is running Microsoft Windows XP Service Pack 2 (SP2), Microsoft Visual Studio 2005 may unexpectedly quit when any one of the following conditions is true:
  • You try to view Microsoft Developer Network (MSDN) documentation in Visual Studio 2005.
  • You try to create a Visual C++ project.
Note This problem has been fixed in Microsoft Windows Server 2003 Service Pack 1 (SP1).

CAUSE

This problem occurs because a change in the Web browser's security model in Windows XP SP2 causes an access violation in MSHTML.dll.

RESOLUTION

Security update information

To resolve this problem, apply the Cumulative Security Update for Internet Explorer (Microsoft Security Bulletin MS05-052). For more information, visit the following Microsoft Web site:

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows XP SP2 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size       File name
   --------------------------------------------------------
   04-Oct-2005  23:51  6.0.2900.2769  3,017,728  Mshtml.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:7/25/2006
Keywords:kbfix kbQFE kbbug kbpubtypekc KB906673 kbAudDeveloper kbAudITPRO