A custom program that uses the RegConnectRegistry function can no longer access the registry of a remote computer in Windows Server 2003 with Service Pack 1 or in an x64-based version of Windows Server 2003 (906570)



The information in this article applies to:

  • Microsoft Windows Server 2003 SP1, when used with:
    • Microsoft Windows Server 2003, Standard Edition
    • Microsoft Windows Server 2003, Enterprise Edition
    • Microsoft Windows Server 2003, Datacenter Edition
    • Microsoft Windows Server 2003, Web Edition
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition

SYMPTOMS

After you apply Microsoft Windows Server 2003 Service Pack 1 (SP1) or install an x64-based version of Windows Server 2003, a custom program that uses the RegConnectRegistry function can no longer access the registry of a remote computer.

This problem may affect computers that are running Microsoft Systems Management Server (SMS) 2003. For example, a Windows Server 2003-based server that is running SMS 2003 may be unable to access the registry on a remote server. Additionally, the SMS 2003 server log file may contain an entry that is similar to the following: ERROR: Could not connect to registry key HKEY_LOCAL_MACHINE\Software\Microsoft\SMS on site server ServerName, sleeping 60 seconds. The operating system reported error 997: Overlapped I/O operation is in progress.Note This problem only occurs when SMS 2003 is running in advanced security mode.

CAUSE

This problem occurs because the RegConnectRegistry function incorrectly uses the security context of the anonymous logon account to connect to the remote computer. The RegConnectRegistry function does not use the account that the function used before you installed Windows Server 2003 SP1.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 SP1 installed on the computer.

Note If you are running an x64-based version of Windows Server 2003, Windows Server 2003 SP1 is already installed. You do not have to reinstall this service pack.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Windows Server 2003, x86-based versions
   Date         Time   Version             Size  File name
   ------------------------------------------------------------------
   25-Aug-2005  07:42  5.2.3790.2516    620,032  Advapi32.dll
   05-Mar-2005  01:30  6.1.22.4         371,936  Updspapi.dll
Windows Server 2003, Itanium-based versions
   Date         Time   Version             Size  File name   Platform
   ------------------------------------------------------------------
   24-Aug-2005  21:14  5.2.3790.2516  1,483,264  Advapi32.dll   IA-64
   24-Aug-2005  21:14  5.2.3790.2516    620,032  Wadvapi32.dll    x86
   24-Aug-2005  21:14  6.1.22.4         639,712  Updspapi.dll   IA-64
Windows Server 2003, x64-based versions
   Date         Time   Version             Size  File name
   ------------------------------------------------------------------
   24-Aug-2005  21:14  5.2.3790.2516  1,051,136  Advapi32.dll
   24-Aug-2005  21:14  5.2.3790.2516    620,032  Wadvapi32.dll
   24-Aug-2005  21:14  6.1.22.4         462,560  Updspapi.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The problem that is mentioned in the "Symptoms" section allows the Kerberos protocol to be used with the Remote Registry service. After you install this hotfix, you may be able to use the Remote Registery service without using the NTLM authentication protocol. For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:7/24/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbpubtypekc KB906570 kbAudITPRO