The Gpresult.exe tool stops responding or displays incorrect results when you run the Gpresult.exe tool together with the "/v" or "/z" switch on a Windows XP-based computer (906450)



The information in this article applies to:

  • Microsoft Windows XP Service Pack 2, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 1a, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Service Pack 1, when used with:
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When you run the Gpresult.exe command-line tool together with the /v or /z switch on a Microsoft Windows XP-based computer, you may experience one or more of the following symptoms:
  • The Gpresult.exe tool stops responding and an access violation error occurs.
  • The Gpresult.exe tool displays incorrect results.
Note This problem occurs only if the data to be displayed contains a "%" character.

CAUSE

This problem occurs because the Gpresult.exe tool does not correctly handle the "%" character.

When the data to be displayed contains a "%" character, the Gpresult.exe tool passes path strings to a printf() function. The printf() function scans the path strings for substitution strings such as "%S." Then, the printf() function tries to make character substitutions by using random data.

RESOLUTION

Service pack information

For more information about how to obtain the latest Windows XP service pack, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Gprslt.exe5.1.2600.2781120,83221-Oct-200501:48x86

WORKAROUND

To work around this problem, use the Microsoft Windows Server 2003 version of the Gpresult.exe tool.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbtshoot kbprb kbHotfixServer kbQFE KB906450 kbAudEndUser kbAudKnowledgeWorker