The Telephony Application Service does not start after you install Visual Studio 2005 common language runtime on Speech Server 2004 (906375)



The information in this article applies to:

  • Microsoft Speech Server 2004 Enterprise Edition
  • Microsoft Speech Server 2004 Standard Edition

SYMPTOMS

The Telephony Application Service does not start after you install Microsoft Visual Studio 2005 common language runtime on Microsoft Speech Server 2004. However, the Speech Engine Service does start. The order of installation is not important. You may receive the following error messages:
TAS was unable to create a worker process. Try restarting TAS, rebooting the computer, or reinstalling Microsoft Speech Server. For more information, see Help and Support Center at http://support.microsoft.com.
TAS was unable to create one or more SALT interpreter instances for the following reason: 80004002. Try restarting TAS, rebooting the computer, or reinstalling Microsoft Speech Server. For more information, see Help and Support Center at http://support.microsoft.com.

CAUSE

This problem occurs because the Speech Server 2004 Telephony Application Service requires the Microsoft .NET Framework 1.1 to start and to operate correctly. However, if a later version of the .NET Framework is installed, the TASWorker.exe file will find only that version.

RESOLUTION

To resolve this problem, add the following code to the Tasworker.exe.config file so that the Telephony Application Service uses the .NET Framework 1.1:
	
<configuration>
	<startup>
		<supportedRuntime version="v1.1.4322"/>
	</startup>
</configuration>
The Tasworker.exe.config file is typically located in the following folder:

C:\Program Files\Microsoft Speech Server\TAS

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:9/22/2006
Keywords:kbtshoot kbprb KB906375 kbAudDeveloper