Systems Management Server 2.0 clients are periodically unable to connect to their client access point (906321)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

SYMPTOMS

Systems Management Server 2.0 clients are periodically unable to connect to their client access point. When this problem occurs, you cannot use the Smsls.bat logon script file to install a Microsoft Systems Management Server (SMS) 2.0 client.

Additionally, you may find entries in the Ccim32.log file that are similar to the following:GetAccessiblePath failed for NAL path ABEXPRT:\\CAP List for site LC1\clidata.box\. Error = 0x80004003
Warning: Unable to check assignment for site "LC1" - #2147942453The operation completed successfully.
Client last reached site LC1 on "2004/02/27 07:54.37"
Client will be considered an orphan after 2004/04/27 08:54.37

CAUSE

This problem occurs when the user who logs on and runs the Smsls.bat logon script file has permission to register .dll files but does not have permission to access the %windir% folder. In this situation, core client components that include the AbNwCli.dll file are installed to the Temp folder. Eventually, the contents of the Temp folder are automatically deleted. When the contents of the Temp folder are deleted, the client that uses the Smsls.bat logon script file is orphaned. Therefore, the entries that are mentioned in the "Symptoms" section appear in the Ccim32.log file.

RESOLUTION

To resolve this problem, follow these steps:
  1. Remove the permissions to register .dll files from the user accounts that are used to log on to SMS 2.0 client computers.
  2. Grant the permissions to access the %windir% folder to the user accounts that are used to log on to SMS 2.0 client computers.
Note Do not use the SMS 2.0 logon point when you use the Smsls.bat logon script to install the SMS 2.0 client.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MajorLast Reviewed:10/3/2005
Keywords:kberrmsg kbtshoot kbprb KB906321 kbAudITPRO